Formule exel à 2 conditions

Résolu/Fermé
Signaler
-
Messages postés
2501
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
16 janvier 2022
-
Bonjour,

j'ai besoin de votre aide pour créer une formule de calcul sur excel :

COLONNE A : SIGLE : école, agence, institut
COLONNE B : STATUT : domanial, locatif, mise à dispo
COLONNE C : VALORISATION : 1 000 €, 2 000 €, 3 000 €

j'aimerai que ma formule additionne la valeur des biens (colonne C) qui sont en domanil (colonne B) et qui sont des écoles (colonne A)

3 réponses

Messages postés
12257
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
3 septembre 2021
2 677
Bonjour,
Essayez voir du côté de la fonction =SOMMEPROD, comme ceci peut être :
=SOMMEPROD((A1:A1000="école")*(B1:B1000="domanial")*(C1:C1000))
!! Vos plages A1:A1000, B1:B1000, C1:C1000 doivent avoir lê même nombre de lignes.
1
merci ça fonctionne.
Mais si l'école s'appelle école st jean, école st luc;;;
j'ai indiqué école** dans le 1er critère mais ma formule ne fonctionne plus !
0
Messages postés
2501
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
16 janvier 2022
1 012
Bonjour,
Les caractères de remplacements * ou ? ne sont pas valides dans SOMMEPROD. Il faut contourner la difficulté.

Si le critère "école" est à gauche dans les cellules du champ A1 :A1000 et que E1='école
SOMMEPROD((GAUCHE(A1:A1000;NBCAR(E1))=E1)*(B1:B1000="domanial")*(C1:C1000))
Si le critère "école" est seulement contenu dans les cellules du champ A1 :A1000
=SOMMEPROD((ESTNUM(CHERCHE("école";A1:A1000))*(B1:B1000="domanial")*(C1:C1000))
0