Excel. Probleme formule avec filtre auto [Résolu/Fermé]

Signaler
Messages postés
42
Date d'inscription
lundi 20 juin 2011
Statut
Membre
Dernière intervention
16 janvier 2012
-
Messages postés
42
Date d'inscription
lundi 20 juin 2011
Statut
Membre
Dernière intervention
16 janvier 2012
-
Bonjour,

J'arrive pas a trouver la solution a ce probleme... desolee si c'est un probleme deja traité. Je pense que je ne tape pas forcement les bons mots clés...

Voila mon probleme, j'ai des filtres automatiques sur mon fichier excel. J'ai des lignes de sous totaux donc avec formule =SOUS.TOTAL(9;C1301:C1309)

Quand j'utilise le filtre automatique d'une autre colonne, mes sous totaux disparaissent. La valeur devient 0!

Comment faire pour filtrer et garder les sous totaux? ( a part faire un copier coller... )

Et une autre question par la meme occasion, toujours un probleme de formule... j'ai la formule =SI(ESTTEXTE(D1306);1;"") pour une des colonnes de mon tableau. Quand j'ajoute une ligne, la formule ne suit pas. Du coup au lieu d'etre =SI(ESTTEXTE(D1307);1;"") , il reste =SI(ESTTEXTE(D1306);1;"") alors que je viens de rajouter une ligne...

Je ne sais pas si j'ai ete tres claire dans mon probleme...

Merci pour toute aide


3 réponses

Messages postés
1505
Date d'inscription
vendredi 25 mai 2007
Statut
Membre
Dernière intervention
31 janvier 2018
134
Bonjour,

Comment as -tu effectué tes sous totaux???

Pour ma part, j'ai sélectionné tout le tableau et 'jai fait données, sous total. Et les sous totaux restent corrects lorsque j'applique un filtre automatique.

Pour la deuxième partie, je ne comprends pas non plus.

Tu sélectionnes la ligne ou tu as ta formule en cliquant sur 1306 et tu fais Insertion??
Normalement, la formule suit.
Messages postés
52670
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
18 novembre 2020
14 610
"Quand j'ajoute une ligne, la formule ne suit pas."
Normal : on n'ajoute pas une ligne n'importe comment ; soit on fait copier/insérer les cellules copiées, soit on insére une ligne et on recopie la formule.
Comment as-tu procédé ?
Messages postés
42
Date d'inscription
lundi 20 juin 2011
Statut
Membre
Dernière intervention
16 janvier 2012
2
Excusez moi pour ce probleme, en fait je ne sais pas moi non plus comment jen suis arrivée la. J'ai du faire une mauvaise manipulation quelque part, du coup j'ai tout recommencé et ca marche. Mais merci quand meme, je ferai attention la prochaine fois que j'insers une ligne.