Ubuntu

[Résolu/Fermé]
Signaler
Messages postés
647
Date d'inscription
mardi 27 avril 2004
Statut
Membre
Dernière intervention
24 janvier 2010
-
Messages postés
647
Date d'inscription
mardi 27 avril 2004
Statut
Membre
Dernière intervention
24 janvier 2010
-
bonjour, jeune débutant sous linux avec Ubuntu, je voudrais avooir quelques renseignements!
j'essaie (ca ne fonctionne pas encore mais je persevères!) de partager mes mails entre linux et windows, sous thunderbird!
j'ai la méthode, reste plus qu'a le faire...
et je voudrait donc proteger mes mails, car si je telecharge des messages avec un virus, qu'il n'aille pas s'executer dans windows..
alors est ce indispensable d'installer un anti virus sous linux ou non, sachant que j'ai avast sous windows???
et si oui, comment on peut faire... simplement!
mais avant, je voudrait savoir aussi comment on peut faire reconnaitre un disque dur formaté en FAT32 sous Ubuntu et le rendre accessible en écriture???
merci d'avance!

13 réponses

Messages postés
7472
Date d'inscription
vendredi 14 octobre 2005
Statut
Contributeur
Dernière intervention
5 juin 2020
898
et je voudrait donc proteger mes mails, car si je telecharge des messages avec un virus, qu'il n'aille pas s'executer dans windows..

Alors, effectivement il faut proteger ses mais avec un antivirus sous windows chose qui apparemment est dejà faite.

alors est ce indispensable d'installer un anti virus sous linux ou non, sachant que j'ai avast sous windows???

Pour linux, c'est pas vitale. Il y en a pleins qui n'utilise pas d'antivirus sous linux.Mais bon perso, je pense que cela n'est pas superflu et qu'il vaut mieux garder de bonne habitude. Je conseille toutde meme d'installer un fiorewall qui est tout aussi indispensable que sous windows: tu peux installer firestarter qui est simple et efficace.
Pour les mails, si tu as avast sous windows ca me semble suffisant.
Si tu veux malgré tout prevenir des risque de virus sous linux, tu peux installer clamav avec comme interface graphique klamav ou avscan comme tu le veux.
Avast est depuis recemment dispo aussi sous linux. Je te conseille de telecharger l'archive *.tar.gz qui contient les binaires: il te suffira de décompresser l'archive et d'aller dans le repertoire decompressé puis dans le repertoire "bin" et enfin de lancer avast en cliquant sur avastgui (il n'y a pas d'installation à faire).
Il faut savoir que sous linux il n'y a pas de protection residente comme sous windows, c'est à dire que l'antivirus ne surveille pas en permenance l'activité du systeme. Il est toutefois possible d'activer la protection résidente avec notemment klamav/clamav mais cela reste assez compliqué pour le debutant et franchement pas necessaire sous linux.

mais avant, je voudrait savoir aussi comment on peut faire reconnaitre un disque dur formaté en FAT32 sous Ubuntu et le rendre accessible en écriture???
Normalement à l'installation d'Ubuntu, les partitions sont reconnues à l'installation et sont montées directement en ecriture: c'est mon cas sous dapper.
Maintenant, tout se gere dans le fichier /etc/fstab.
Pour moi par exemple j'ai la ligne suivante pour ma partition en fat32:
/dev/hdb6 /media/hdb6 vfat defaults,utf8,umask=007,gid=46 0 1
/dev/hdb6 : le device correspondant à ma partition
/media/hdb6 : le repertoire ou est montée cette partition
vfat: le type de systeme de fichier, vfat correspond au systeme de fichier fat
defaults,utf8,umask=007,gid=46 : suite de parametres pour le montage de la partuition
utf8: encodage de caractère pour le nommage des fichiers/repertoires.
gid=46: indique le groupe auquel appartient toute la partition; le groupe est désigné par son id = 46.
umask=007: permet de spécifier les droits (lecture/ecriture/execution)
En fait, pour connaitre les droits, on fait une soustraction: 777-umask.
Ici, on a 777-007=770.
le premier chiffre en partant de la gauche corerspond aux droits du priprio (par defaut le root): ici le 7=4(lecture)+2(ecriture)+1(execution) donne tous les droits au root.
le second chiffre corespond au groupe: pareil le groupe qui est donc celui possèdant l'id 46 a tous les droits.
Enfin le dernier correspond aux autres qui là n'ont aucun droit.

Ainsi, pour pouvoir les droits, il faut soit etre le root (cela n'est franchement pas recommandé) soit faire parti du groupe à l'id 46 (c'est la solution!)
Donc, sous ubuntu, tu vas dans systeme->administration->utilisateurs et groupes->onglet groupe et tu double-cliques sur le groupe à l'id=46 et tu t'y inseres.
Tu peux aussi definir un autre gid, le tout est d'etre membre de ce groupe pour pouvoir acceder à la partuttion.

Je te conseil toutefois de lire ce tuto qui explique bien la syntaxe du fstab:
http://lea-linux.org/cached/index/Fstab.html
Messages postés
647
Date d'inscription
mardi 27 avril 2004
Statut
Membre
Dernière intervention
24 janvier 2010
58
salut et ok pour l'antivirus,
en fait, j'avais lu le mail indiquant la soirtie d'avast pour linux, d'où ma question, mais yoann m'a demandé de faire un nouveau post...
je précise quand meme que je suis connecté au travers d'un modem routeur qui intègre un pare feu...
sous windows, je n'utilise donc pas de pare feu suppémentaire...
est ce utile sous linux?

sinon ok pour les partitions, je vais regarder...
en fait, elle n'est pas monté depuis le départ, car lorsque j'ai installé linux, cette partition était en NTFS et je me suis dit que pour communiquer avec linux, ce searit plus partique de la mettre en fat32...
voia, j'essaie et je reviens...
merci d'avance!
Messages postés
7472
Date d'inscription
vendredi 14 octobre 2005
Statut
Contributeur
Dernière intervention
5 juin 2020
898
sous windows, je n'utilise donc pas de pare feu suppémentaire...
est ce utile sous linux?


Et bien c'est comme windows, si tu as dejà un firewall (routeur) pas besoin d'en avoir un second.
Messages postés
647
Date d'inscription
mardi 27 avril 2004
Statut
Membre
Dernière intervention
24 janvier 2010
58
salut, ok et merci pour tes réponses...
alors voila où j'en suis!
pour l'antivirus, je vais voir plus tard...
pour le disque dur, j'ai bien trouvé le fichier, mais je ne peux l'ouvrir sous ma sessions qu'en lecture seule...
de plus, je n'arrive pas a me connecter en root, il me faut un mot de passe que je n'ai jamais rentré...
enfin, les disque sont bien pour l'ID 46, et apparement, ma session est bien comprise dedans!

encore merci
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 545
Salut,

je n'arrive pas a me connecter en root, il me faut un mot de passe que je n'ai jamais rentré...

pour exécuter une commande en tant que root utilise la commande sudo
commande sudo comment ca marche#2

Pour te connecter en root tu peux utiliser sudo -s

lami20j
Messages postés
647
Date d'inscription
mardi 27 avril 2004
Statut
Membre
Dernière intervention
24 janvier 2010
58
salut et merci pour ta réponse, j'avais lu ca effectivement apres avoir posté mon message...
pas encore eu le temps de l'utiliser mais je vais voir!
Messages postés
7472
Date d'inscription
vendredi 14 octobre 2005
Statut
Contributeur
Dernière intervention
5 juin 2020
898
Normalement sous ubuntu quand les droits du root sont requis une bote de dialogue demande alors son mot de passe: attention, c'est son propre mot de passe qu'il faut pas celui du root.
En fait, sous ubuntu, le compte administrateur (le root) n'est pas crée, par contre l'utilisateur crée (son propre compte donc) possède les droits du root. C'est poue cela qu'il faut mettre son propre mot de passe et pas celui du root.

Voir le lien donné par lami20j pour plus de precision
Messages postés
19599
Date d'inscription
vendredi 28 décembre 2001
Statut
Modérateur
Dernière intervention
2 janvier 2020
3 556
Bonjour,

Ce n'est pas tout à fait ainsi sous Ubuntu. De fait, le premier utilisateur créé possède les droits roots d'où la necessité de mettre le mot de passe de ce premier utilisateur avec certaines commandes (sudo). D'où aussi la recommandation dans certains cas (plusieurs utilisateurs) de ne surtout pas donner ce mot de passe aux autres ;-)
Messages postés
647
Date d'inscription
mardi 27 avril 2004
Statut
Membre
Dernière intervention
24 janvier 2010
58
Bonjour,
voila, après quelques temps de recherche, je suis parvenu à éditer le fichier fstab avec les droites d'écritures...
j'ai modifier mon fichier qui donne ceci:

/dev/sda7 / ext3 defaults,errors=remount-ro 0 1
/dev/sda1 /media/sda1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/sda5 /media/sda5 vfat defaults,nls=utf8,umask=007,gid=46 0 1
/dev/sdb1 /media/sdb1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/sdb5 /media/sdb5 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/sda6 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0


par contre, même lorsque je redémarre mon système, il ne veut toujours pas me monter ma partition en fat...
et lorsque je vais dans administration -> système -> disque, il m'indique que je ne peux pas activer la partition sur /dev/sda5!!!

alors je ne sais plus trop, malgrès tout ce que j'ai pu lire...

mais pour la commande sudo, le coup est pigé, merci messieurs!

@+
Messages postés
7472
Date d'inscription
vendredi 14 octobre 2005
Statut
Contributeur
Dernière intervention
5 juin 2020
898
question bete mais est ce que le repertoire /media/sda5 existe?
Et que donne la commande "mount /dev/sda5" ?
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 872
Salut,

Pour appuyer l'interrogation de Zempachi, peux-tu nous poster les résultats des commandes suivantes :
sudo /sbin/fdisk -l
cat /etc/fstab  (histoire qu'on ait une vue globale)
ls -l /media
mount
Merchi ;-))
Messages postés
647
Date d'inscription
mardi 27 avril 2004
Statut
Membre
Dernière intervention
24 janvier 2010
58
bonjour et merci de vos réponses!
pour ma part, je suis désolé de répondre si tardivement, mais le boulot est dur en ce moment et ne me laisse pas autant de temps que je le souhaiterais...

quoi qu'il en soit, voici les réponses à vos questions:
alors pour Zempachi, oui, le rep /media/sda5 existe, puisque le disque dur était monté dans ce rep avant que je ne le change de format...
pour les autres questions, voici ce que ca ma donné dans la console:

kephas@kephas:~$ mount /dev/sda5

mount: seul l'usager ROOT peut monter /dev/sda5 sur /media/sda5

kephas@kephas:~$ sudo /sbin/fdisk -l

Disque /dev/sda: 40.0 Go, 40020664320 octets
255 têtes, 63 secteurs/piste, 4865 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Périphérique Amorce Début Fin Blocs Id Système
/dev/sda1 * 1 1912 15358108+ 7 HPFS/NTFS
/dev/sda2 1913 4865 23719972+ f W95 Etendu (LBA)
/dev/sda5 1913 4207 18434556 b W95 FAT32
/dev/sda6 4208 4245 305203+ 82 Linux swap / Solaris
/dev/sda7 4246 4865 4980118+ 83 Linux

Disque /dev/sdb: 40.0 Go, 40020664320 octets
255 têtes, 63 secteurs/piste, 4865 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets

Périphérique Amorce Début Fin Blocs Id Système
/dev/sdb1 1 643 5164866 7 HPFS/NTFS
/dev/sdb2 644 4865 33913215 f W95 Etendu (LBA)
/dev/sdb5 644 4865 33913183+ 7 HPFS/NTFS
kephas@kephas:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/sda7 / ext3 defaults,errors=remount-ro 0 1
/dev/sda1 /media/sda1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/sda5 /media/sda5 vfat defaults,nls=utf8,umask=007,gid=46 0 1
/dev/sdb1 /media/sdb1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/sdb5 /media/sdb5 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/sda6 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0

kephas@kephas:~$ ls -l /media

total 56
lrwxrwxrwx 1 root root 6 2006-06-05 23:36 cdrom -> cdrom0
drwxr-xr-x 2 root root 4096 2006-06-05 23:36 cdrom0
dr-xr-x--- 1 root plugdev 8192 2006-06-10 11:21 sda1
drwxr-xr-x 2 root root 4096 2006-06-05 23:36 sda5
dr-xr-x--- 1 root plugdev 36864 2006-06-13 22:22 sdb1
dr-xr-x--- 1 root plugdev 4096 2006-06-04 19:09 sdb5

kephas@kephas:~$ mount

/dev/sda7 on / type ext3 (rw,errors=remount-ro)
proc on /proc type proc (rw)
/sys on /sys type sysfs (rw)
varrun on /var/run type tmpfs (rw)
varlock on /var/lock type tmpfs (rw)
procbususb on /proc/bus/usb type usbfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
devshm on /dev/shm type tmpfs (rw)
lrm on /lib/modules/2.6.15-23-386/volatile type tmpfs (rw)
/dev/sda1 on /media/sda1 type ntfs (rw,nls=utf8,umask=007,gid=46)
/dev/sdb1 on /media/sdb1 type ntfs (rw,nls=utf8,umask=007,gid=46)
/dev/sdb5 on /media/sdb5 type ntfs (rw,nls=utf8,umask=007,gid=46)


Je précise aussi que comme m'avait demandé Zempachi, j'ai regardé et je suis bien inscrit dans l'ID46

Voila, si vous avez d'autres choses à me proposer, je suis toujours preneur!
Messages postés
647
Date d'inscription
mardi 27 avril 2004
Statut
Membre
Dernière intervention
24 janvier 2010
58
Bonjour,
je viens d'essayer une nouvelle fois, mais ça ne fonctionne toujours pas...
même en faisant mount avec les droits de root:

kephas@kephas:~$ sudo mount /dev/sda5
Password:
mount: type erroné de système de fichiers, option erronée, super bloc erroné sur  /dev/sda5, codepage manquante ou autre erreur
Dans quelques cas certaines informations sont utiles dans syslog - essayez
dmesg | tail  ou quelque chose du genre



donc si vous avez autres choses je suis toujours preneur!
Messages postés
647
Date d'inscription
mardi 27 avril 2004
Statut
Membre
Dernière intervention
24 janvier 2010
58
bonjour,
finallement, après avoir attendu vos réponse, j'ai résolu autrement mon problème en réinstallant mon système...
merci quand même pour votre aide!
a bientôt