[Debian] Autoremove or not autoremove ?

Fermé
Utilisateur anonyme - 9 juil. 2011 à 16:29
 Manu - 10 juil. 2011 à 02:20
Bonjour,
Voici ce que j'ai d'affiché dans ma console quand j'ai supprimé un paquet (banshee)
La liste est longue, je me demande si je peut faire un "apt-get autoremove"

Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  x11-apps libmono-data-tds2.0-cil python-coherence python-bugbuddy
  gnome-session-canberra xdg-user-dirs-gtk usb-modeswitch geoclue
  gtk2-engines-smooth dnsmasq-base tomboy python-evolution espeak ekiga
  libepc-common libmono-security2.0-cil update-notifier-common xfonts-75dpi
  libgnome-bluetooth7 libndesk-dbus1.0-cil rpm2cpio libmono-addins-gui0.2-cil
  gcalctool libmono-wcf3.0-cil libopal3.6.8 gnome-backgrounds libbrlapi0.5
  telepathy-gabble gnome-search-tool libmono-system2.0-cil tcptraceroute
  xfonts-scalable python-twisted-bin update-notifier baobab
  libfreerdp-plugins-standard python-mako gtk2-engines hamster-applet
  libmono-sqlite2.0-cil network-manager-gnome libsrtp0 gnome-system-log
  doc-base gucharmap libdiscid0 geoclue-localnet totem-plugins gnome-games
  obexd-client cheese gdebi python-openssl libgpod-common libtaglib2.0-cil
  obex-data-server libgnomepanel2.24-cil libmono-corlib2.0-cil
  gnome-disk-utility python-louie python-pyatspi cli-common python-louis
  liblouis-data gnome-mag rhythmbox libboost-python1.42.0 libnm-util1
  libtelepathy-farsight0 libmono-cairo2.0-cil libgexiv2-0 empathy-common
  python-httplib2 python-nevow libcheese-gtk18 geoclue-yahoo
  libndesk-dbus-glib1.0-cil libgupnp-1.0-3 libgstfarsight0.10-0
  freedesktop-sound-theme usb-modeswitch-data gnome-themes-extras
  mobile-broadband-provider-info evolution-exchange libpcap0.8 libcolorblind0
  transmission-gtk python-zope.interface libmono-i18n-west2.0-cil
  python-twisted-conch librpmio1 libapr1 librpm1 guile-1.8-libs
  update-manager-gnome seahorse rpm-common empathy podsleuth libsqlite0
  libchamplain-0.4-0 xdg-user-dirs gdebi-core libmono-system-messaging2.0-cil
  python-twisted-web gvfs-bin python-axiom software-center
  libmono-posix2.0-cil libaprutil1-ldap mono-runtime telepathy-salut libgpod4
  libmono-addins0.2-cil libgeoclue0 libgnome2.24-cil xorg-docs-core
  python-serial gnome-cards-data libgalago3 x11-session-utils gnuchess-book
  gnome-nettool transmission-common gnome-codec-install dasher
  gnome-screenshot shotwell python-epsilon update-manager-core libportaudio2
  gnome-games-extra-data python-webkit gconf-editor gnome-accessibility-themes
  python-pam libelf1 libcryptui0 libgdu-gtk0 libgdata-common simple-scan
  python-aptdaemon libgnome-mag2 libgail-gnome-module gnome-orca
  libclutter-gtk-0.10-0 libmono-messaging2.0-cil libgee2 python-brlapi
  network-manager python-clientform gnome-system-tools libepc-ui-1.0-2
  epiphany-extensions eog hal binfmt-support libmono-system-data-linq2.0-cil
  liblouis2 libavahi-ui0 totem-coherence libmono-system-data2.0-cil
  libnm-glib-vpn1 python-gtkglext1 dasher-data libgnome-vfs2.0-cil gok
  libmono2.0-cil x11-xfs-utils python-xdg libaprutil1-dbd-sqlite3
  libtelepathy-glib0 espeak-data libmono-zeroconf1.0-cil mono-gac python-vte
  libnm-glib2 gnome-bluetooth gnome-user-share modemmanager
  gconf-defaults-service libglade2.0-cil apache2.2-bin seahorse-plugins
  libopenobex1 libspeexdsp1 cheese-common sound-juicer libart2.0-cil vino
  mousetweaks aptdaemon python-mechanize libnotify0.4-cil libwebkit1.1-cil
  libglib2.0-cil mono-2.0-gac python-tagpy xfonts-100dpi libgconf2.0-cil
  python-aptdaemon-gtk ppp python-twisted-core python-utidylib libespeak1 tcl
  libapache2-mod-dnssd libmono-sharpzip2.84-cil python-configobj libfs6
  nautilus-sendto libfreezethaw-perl libgdata7 libepc-1.0-2 tcl8.4
  libgdata1.4-cil dmz-cursor-theme libgnome-speech7 liferea libpt2.6.7
  remmina-plugin-rdp libgupnp-igd-1.0-3 gtk2-engines-pixbuf gnome-themes-more
  python-gdbm libmono-system-web2.0-cil python-gst0.10 media-player-info
  python-markupsafe libchamplain-gtk-0.4-0 remmina-plugin-vnc gnome-games-data
  geoclue-manual libmusicbrainz3-6 gstreamer0.10-tools liferea-data hal-info
  geoclue-hostip python-gdata gnome-office libboo2.0.9-cil gnuchess
  libfreerdp0 libnice0 libgtk2.0-cil totem gstreamer0.10-nice
  python-pkg-resources libssh-4 totem-mozilla python-beautifulsoup
  python-pysqlite2 gnome-themes rhythmbox-plugin-cdrecorder rhythmbox-plugins
  libaprutil1 p7zip-full libgmime2.4-cil python-rdflib remmina-plugin-data
  python-feedparser libnet1 totem-common libmldbm-perl freeglut3 python-crypto
  libgssdp-1.0-2 libtidy-0.99-0 nautilus-sendto-empathy file-roller libgdiplus
  python-pyasn1 telepathy-mission-control-5 remmina python-opengl
Veuillez utiliser « apt-get autoremove » pour les supprimer.

5 réponses

Leptitchat Messages postés 28 Date d'inscription vendredi 8 juillet 2011 Statut Membre Dernière intervention 16 juillet 2011 11
9 juil. 2011 à 17:06
C'est à toi de voir si tu as encore besoin ou pas des paquets de cette liste.
autoremove supprime les paquets qui ne sont plus nécessaires, comme les dépendances d'un paquet supprimé, ou les paquets dont une des dépendances à été supprimée.
Utilisateur anonyme
9 juil. 2011 à 17:39
Ce message m'est affiché depuis que j'ai installé Débian.
Mais je ne connais pas tous ces paquets
La liste me parais un peu trop longue pour des paquets non utilisés.
takefive Messages postés 1009 Date d'inscription dimanche 28 décembre 2008 Statut Membre Dernière intervention 29 août 2019 81
9 juil. 2011 à 18:35
Salut,
Déjà, il a rhythmbox,empathy,totem-mozilla etc etc....Tout ça va sauter ....je trouve ça étrange car c'est utilisé.Il faudra tout réinstaller pour que ça redevienne fonctionnel.
Comprend pas là..
0
Leptitchat Messages postés 28 Date d'inscription vendredi 8 juillet 2011 Statut Membre Dernière intervention 16 juillet 2011 11
9 juil. 2011 à 20:44
Je crois que ça m'était arrivé en désinstallant un métapaquet quand j'étais sous ubuntu, ubuntu-desktop. Essaie apt-get check.
A première vue il va faire sauter Gnome : tu risques de te retrouver sans interface graphique. Donc il doit y a voir un problème de dépendance quelque part.

Par contre avec Debian, sauf pour une migration de 5.0 vers 6.0, il faut utiliser aptitude à la place de apt-get.

Si jamais tu ne peux te connecter en graphique, il faut utiliser le 2e choix dans le menu grub, se connecter root et installer avec aptitude le paquet gnome.

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Salut, essayes plutôt avec aptitude purge [nom du paquet] après un upgrade seulement.

# aptitude update && aptitude full-upgrade 
# aptitude purge banshee


Bien souvent lorsque apt flingue autant de paquets lors d'une désinstallation, c'est parce que le sources.list n'a pas été rechargé.

Tu peux voir les réelles dépendances de banshee avec

# aptitude show banshee


Déjà il n'y a pas de network-manager-gnome entre autres.