Formule excel (moyenne avec critère) [Résolu/Fermé]

Signaler
Messages postés
81
Date d'inscription
mardi 12 octobre 2010
Statut
Membre
Dernière intervention
9 novembre 2011
-
Messages postés
81
Date d'inscription
mardi 12 octobre 2010
Statut
Membre
Dernière intervention
9 novembre 2011
-
Bonjour à tous,

J'ai encore besoin de votre aide :)

Je travail sur un tableau de registre du personnel et j'ai besoin de calculer la moyenne d'age :
- J'ai une colonne nommée actif, avec pour choix : oui ou non
- J'ai une cellule avec la moyenne d'age des actifs oui et non

Sauf que je voudrais calculer la moyenne d'age des salariés actifs oui ?

Quelqu'un pourrait il me renseigner?

Merci beaucoup :)

Berzi

2 réponses

Messages postés
12247
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
10 février 2021
2 574
Bonjour,
Les actifs (oui non) en colonne A de A12 à A20, les âges en colonne C, de C12 à C20 :
=MOYENNE(SI((A12:A20="oui");(C12:C20)))
Formule matricielle Il convient donc de la valider par "CTRL+Shift+Entrée" au lieu de "Entrée". Si la manip est bien faite, ta formule apparait entre {}.
Sources Michel_m malheureusement lien désactivé...
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
81
Date d'inscription
mardi 12 octobre 2010
Statut
Membre
Dernière intervention
9 novembre 2011
1
Résolu!! Décidement tu m'aides beaucoup!!

Merci beaucoup pour les réponses précieuses :)

Bonne journée :)

Berzi
Messages postés
2
Date d'inscription
jeudi 14 décembre 2006
Statut
Membre
Dernière intervention
21 juin 2011
1
Bonjour

je n'ai pas la réponse complète mais il faut creuser avec les formules NB.SI et NBVAL
Messages postés
81
Date d'inscription
mardi 12 octobre 2010
Statut
Membre
Dernière intervention
9 novembre 2011
1
Bonjour Pnovelli13, Merci pour ta réponse mais celle de Pijaku qui m'a également aidé hier sur une autre formule, fonctionne parfaitement!!

Merci pour ton aide également :)

Bonne journée :)

Berzi