Compter toutes les cellules sauf A1

Résolu/Fermé
espritbiz - 14 juin 2011 à 14:59
 espritbiz - 14 juin 2011 à 16:56
Bonjour tout le monde,

J'ai une question dont je suppose que la réponse est simple... mais je ne la trouve pas!
Je veut calculer le nombre de cellules remplie de ma colonne A, donc =somme(A:A), mais sans compter la première cellule qui comprend le titre... comment je peux faire? somme(A:A)-A1 ne fonctionne malheureusement pas...
Merci pur votre aide!!!



4 réponses

Mike-31
Messages postés
17941
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 mai 2022
4 939
14 juin 2011 à 15:03
Salut,

pourquoi ne pas définir les bornes

=SOMME(A2:A100)
0
oui, c'est ce que j'ai fait pour dépanner (jusque A30000...) mais j'aurais bien voulu avoir une fonction "propre"... surtout si après je ne veut pas exclure A1 mais A12 par exemple...
et merci pour la réponse ultra rapide :-)
0
Mike-31
Messages postés
17941
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 mai 2022
4 939
14 juin 2011 à 15:26
Re,

Alors peut être cette formule qui prendra en compte la colonne A à partir de la cellule A10 par exemple

=SOMME(DECALER($A$10;;;NBVAL(A:A)))
0
Raymond PENTIER
Messages postés
56075
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
17 mai 2022
17 212
14 juin 2011 à 16:49
Bonjour espritbiz. S'agit-il de trouver :

- le nombre de cellules non vides "Je veut calculer le nombre de cellules remplie de ma colonne A" ?
La réponse serait =NBVAL(A:A)-1

- la somme des valeurs dans les cellules de la colonne "donc =somme(A:A)" ?
La réponse serait =SOMME(A:A)
0
merci, vos deux solutions m'aident, donc "problem solved" :-)
0