Tuto freeradius + ldap

Résolu
Bonjour à tous,

J'ai beau chercher en long et en travers sur google, je n'arrive pas à trouver un bon tutoriel pour mettre en place un radius + ldap, quelqu'un aurait un lien?

Merci d'avance =)

5 réponses

  1. Contributeur
    Salut,

    https://tldp.org/HOWTO/archived/LDAP-Implementation-HOWTO/radius.html
    http://www.davidgis.fr/blog/index.php?2008/01/19/276-freeradius-et-openldap
    http://www.system-linux.net/config/freeradius-ldap-hostapd/tuto-court.html
    http://www.linuxhomenetworking.com/...
    http://wiki.diderot.org/index.php/Freeradius_-_EAP-PEAP_avec_OpenLDAP
    2
    1. C'est ça mon pb, le ldap fonctionne et marche impec et j'aimerais trouver un tuto expliquant bien comment lié les configuration radius avec les conf ldap :)
      0
      1. Merci zipe31,

        Mais maintenant j'ai un petit probleme, dans mon ldap j'ai l'utilisateur root + 2 autres.

        Lorsque je lance un radtest avec l'utilisateur root, j'ai un Access-Accept mais quand j'essaye avec un des 2 autres utilisateur que 'jai crée sur mon ldap j'ai un Access-Reject.

        J'arrive toujours pas a déterminer d'où ça peut venir, si vous avez un tuyau...

        Merci ! :D
        0
        1. Bon j'ai trouvé comment lié les utilisateurs de mon ldap a mon freeradius, donc je vais la poster si sa peut aider ;)

          1 => S'assurer que les modules "ldap" sont décommentés dans els fichiers radiud.conf, /etc/freeradius/site-available/default, /etc/freeradius/site-available/inner-tunnel

          2 => éditer /etc/freeradius/clients.conf :

          client localhost {
          ipaddr = 127.0.0.1
          secret = votre_secret_nas_radius
          nastype = other
          }

          3 => éditer /usr/share/freeradius/dictionary et y rajouter :

          VALUE Auth-Type LDAP 5

          4 => éditer /etc/freeradius/users et y rajoutez :

          DEFAULT Auth-Type := LDAP
          Fall-Through = 1

          Et voila normalement c'est buen ! :D
          0
          1. Contributeur
            Merci du retour ;-))
            0
          2. merci !
            0
          3. Mettre :
            DEFAULT Auth-Type := LDAP
            Fall-Through = 1

            n'apporte que des erreurs et si on lance est en mode debug freeradius (sudo freeradius -X) il nous crache une vilaine erreur !

            Il ne FAUT PAS mettre ça ^^

            Si on passe par un annuaire LDAP, il faut commenté l'utilisateur du fichier user dans /sites-enabled/default ET (si on utilise un tunnel crypté EAP-TTLS) dans /sites-enabled/inner-tunnel

            le fichier user n'à donc plus de raison d'être (ce qui est logique étant donné que l'on passe par LDAP)...
            0