Comment faire des statistiques sur excel

Fermé
-
Messages postés
1
Date d'inscription
lundi 22 juillet 2019
Statut
Membre
Dernière intervention
22 juillet 2019
-
Bonjour,

sur excel 2007, j'ai crée une liste des patients avec noms prenoms date de naissance adresse et code postal; en bleu les hommes et en rose les femmes. a partir de ce tableau, je voudrais faire des statistiques avec le pourcentage d'hommes et de femmes; merci de m'aider, cela fait 10 ans que je ne me sers plus d'excel et c'est le néant !

A voir également:

2 réponses

Messages postés
77
Date d'inscription
lundi 28 juillet 2008
Statut
Membre
Dernière intervention
4 septembre 2011
25
Bonjour,

Alors, je vais essayer de t'expliquer du mieux que je peux.... Il faut que que tu fasse le total de tous les patients homme et pareillement pour les femmes, fait aussi le total de l'ensemble des patients.

Si le total patient = 60, total femme= 25, total homme= 35: dans une cellule tu rentre la formule suivante:
- pour les femmes"= 25x100/60"
- pour les hommes "=35x100/60"

Il après pour que ça s'affiche en pourcentage (si se n'est pas automatique) faire propriété nombre %.

Si tu veux je peux t'envoyer un modéle de tableau! Fait le moi savoir si c'est le cas!
je veux des information pour le statistique
Messages postés
55453
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
28 janvier 2022
17 228
Quelles information ?
Messages postés
1
Date d'inscription
lundi 22 juillet 2019
Statut
Membre
Dernière intervention
22 juillet 2019

merci beaucoup
Messages postés
26411
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 janvier 2022
6 191
Bonjour

Le problème est que vous identifiez les sexes par couleur, c'est gentil en rose et bleu , mais ça impose une macro sur excel.
Si vous pouvez inclure une colonne sexe (F ou H) dans votre tableau sera plus simple de compter les F et les H, avec la formule:
=NB.SI(champ;"F") et NB.SI(Champ;"H")

(Rien n'empêche ensuite un format conditionnel qui passera le nom en rose ou bleu une fois le code entré)

toutefois il y a un moyen statique de compter les cellules de couleur, à condition de créer une colonne de 1 en continu en face des lignes, rose ou bleu.
soit pour l'exemple:
votre liste de nom de A2 à A1000, avec des cellules rose ou bleu
en colonne B placer 1 sur chaque ligne
en B1 la formule:
=SOUS.TOTAL(9;B1:B1000)
sélectionnez A1:B1000
Données / Filtre/cliquez sur la flêche en A2 et choisissez:
filtrer par couleur
la formule vous donnera le nombre de cellule de la couleur choisie
si vous choisissez sélectionner tout, vous aurez le nombre de nom

pour les % une fois que vous avez ces valeurs,
=Total des hommes / total des noms
dans une cellule excel formatée en standard.

cette méthode ne suivra pas, bien entendu, les mises à jour du tableau

Crdlmnt


Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?