Nombre entier excel [Résolu/Fermé]

Signaler
-
Messages postés
8206
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
9 octobre 2020
-
Bonjour,

je cherche la formule qui permet de "détecter" automatiquement les nombres entiers (ou décimaux) dans une liste, et si cette condition est vraie --> mettre un * dans la colonne voisine comme dans l' exemple c après :

colonne A colonne B
1 *
1.2
1.3
2 *
3 *
3.2

merci d'avance de votre réponse

4 réponses

Messages postés
25366
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 octobre 2020
5 521
Bonsoir
une solution parmi d'autres:
=SI(A1-ENT(A1)=0;"*";"")
qui détectera les nombres entiers
ou encore:
=SI(MOD(A1;ENT(A1))=0;"*";"")
crdlmt




Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?
17
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

ca marche merci, et si dans ma liste j'ai une valeur "batarde", par exemple 1D, ca ne fonctionne plus!! y-a t-il un moyen de remédier à cela!
Bonjour,

en colonne B tu mets la formule suivante : =SI(A1=ENT(A1);"*";"")

et tu recopies vers le bas (en partant du principe que tes valeurs sont stockées à partir de A1
ca marche merci, et si dans ma liste j'ai une valeur "batarde", par exemple 1D, ca ne fonctionne plus!! y-a t-il un moyen de remédier à cela!
Messages postés
17242
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
6 octobre 2020
4 284
Salut,

que veux tu dire par valeur batarde, donne un exemple

Mike-31
Messages postés
8206
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
9 octobre 2020
1 488
Si tu considère une valeur "bâtarde" comme une valeur entière :

=SI(ENT(N(A1))=N(A1);"*";"")

sinon :

=SI(ET(ESTNUM(A1);ENT(N(A1))=N(A1));"*";"")
Messages postés
8206
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
9 octobre 2020
1 488
Bonjour,

En B1 :
=SI(ENT(A1)=A1;"*";"")

puis recopier vers le bas.