Nombre entier excel

Résolu/Fermé
horus63 - 21 mars 2011 à 20:44
Patrice33740
Messages postés
8549
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
7 mai 2022
- 21 mars 2011 à 23:01
Bonjour,

je cherche la formule qui permet de "détecter" automatiquement les nombres entiers (ou décimaux) dans une liste, et si cette condition est vraie --> mettre un * dans la colonne voisine comme dans l' exemple c après :

colonne A colonne B
1 *
1.2
1.3
2 *
3 *
3.2

merci d'avance de votre réponse

A voir également:

4 réponses

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 267
Modifié par Vaucluse le 21/03/2011 à 20:50
Bonsoir
une solution parmi d'autres:
=SI(A1-ENT(A1)=0;"*";"")
qui détectera les nombres entiers
ou encore:
=SI(MOD(A1;ENT(A1))=0;"*";"")
crdlmt




Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?
17
ca marche merci, et si dans ma liste j'ai une valeur "batarde", par exemple 1D, ca ne fonctionne plus!! y-a t-il un moyen de remédier à cela!
0