Excel nombre negatif selon résultat autre case

Résolu/Fermé
theo - 1 mars 2011 à 10:44
 theo - 1 mars 2011 à 16:24
Bonjour,
J'aimerai savoir comment mettre une de mes cases automatiquement négatives, si une autre case de la même ligne a comme texte "vente" et non "achat".
Merci pour votre réponses



1 réponse

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 265
Modifié par Vaucluse le 1/03/2011 à 11:27
Bonjour
=SI(A1="vente";-B1;B1)
avec bien sur le code vente ou achat en A1 et le montant en B1
crdlmnt


Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?
0
Merci pour ce début de réponse mais ca ne veut pas marcher (jai un ancien Excel en anglais, j'ai donc mis IF). J'ai la colonne A avec mes ventes et achats et dans la B les montants, ayant des centaines de nombres je ne veux pas faire manuellement
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 265
1 mars 2011 à 12:25
Qu'appelez vous manuellement?
vous entrez la, formule en colonne C ligne 1, la tirez vers le bas et si besoin,ensuite, vous copier la colonne C1 et collage spécial / Valeur sur colonne B
ensuite vous pourrez éliminer la colonne C
crdlmnt
0
Parfait merci, il fallait juste que je mette des virgules et non des points virgules
0
Une dernière chose comment je fais si en plus de "vente" je souhaite aussi mettre une négation pour "sorties"
Merci
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 265
1 mars 2011 à 16:15
re
=SI(OU(A1="vente";A1="sortie");-B1;B1)
à adapter à l'anglais avec IF et virgule :--)
crdlmnt
0