Excel nombre negatif selon résultat autre case [Résolu/Fermé]

Signaler
-
 theo -
Bonjour,
J'aimerai savoir comment mettre une de mes cases automatiquement négatives, si une autre case de la même ligne a comme texte "vente" et non "achat".
Merci pour votre réponses



1 réponse

Messages postés
25761
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2021
5 724
Bonjour
=SI(A1="vente";-B1;B1)
avec bien sur le code vente ou achat en A1 et le montant en B1
crdlmnt


Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?
Messages postés
25761
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2021
5 724
Qu'appelez vous manuellement?
vous entrez la, formule en colonne C ligne 1, la tirez vers le bas et si besoin,ensuite, vous copier la colonne C1 et collage spécial / Valeur sur colonne B
ensuite vous pourrez éliminer la colonne C
crdlmnt
Parfait merci, il fallait juste que je mette des virgules et non des points virgules
Une dernière chose comment je fais si en plus de "vente" je souhaite aussi mettre une négation pour "sorties"
Merci
Messages postés
25761
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2021
5 724
re
=SI(OU(A1="vente";A1="sortie");-B1;B1)
à adapter à l'anglais avec IF et virgule :--)
crdlmnt
C'est parfait