Webacula login

Résolu
Bonjour,
Lorsque que j'essair d'atteindre mon interface web avec l'adresse suivant:
http://localhost/webacula/html
J'ai cette adresse qui est chargé:
http://localhost/webacula/html/auth/login
et une pas 404 NOT FOUND
Ce qui est logique puisque ce dossier n'existe pas.
Je suis bloqué.
Merci de m'aider.

Voici mon error.log d'apache
[Fri Feb 25 11:50:47 2011] [error] [client 127.0.0.1] PHP Fatal error: Using $this when not in object context in /var/www/webacula/html/auth/login.phtml on line 3,

9 réponses

  1. Modérateur
    Ce qui est logique puisque ce dossier n'existe pas.
    Je suis bloqué.


    Quel dossier n'existe pas ? Quel est le DocumentRoot configuré pour webacula (cf /etc/apache2/sites-enabled).

    Voici mon error.log d'apache
    [Fri Feb 25 11:50:47 2011] [error] [client 127.0.0.1] PHP Fatal error: Using $this when not in object context in /var/www/webacula/html/auth/login.phtml on line 3,


    Sans le reste du code c'est malheureusement inexploitable. Tu peux toujours essayer de copier coller le message d'erreur dans google, tu n'es sans doute pas la première personne à avoir le problème.

    Bonne chance
    1. Merci pour l'aide,
      Dans le dossier apache/sites-enabled g une fichier 000-default dans lequel est spécifié que le document root est /var/www
      Le dossier qui n'existe pas, c'est auth/ et le login.phtml non plus.
      Et est ce que g quelque chose a faire a vec le dossier sites-enabled.
  2. Bon j'ai avancé,
    en faite il fallait taper l'adresse suivante
    http://localhost/webacula/index.php
    ce qui me renvoit vers l'adresse suivante
    http://localhost/webacula/index.php/auth/login
    maintenant j'arrive a me logué sur l'interface web mais tout les liens me renvoi sur la page de login
    quelqu'un aurait une idée ?
    1. J'ai déja regardé le tuto de azerttyu.net mais c'est pour une version 3. Or la dernière verison disponible et par la même occasion celle que j'installe, du moins j'essais, est la 5.
      J'ai suivi le fichier d'install fournis dans le fichier compréssé de webacula-5, mais qui n'a pas l'air au point.
      Ce que j'ai fait en plus, c'est configurer les fichiers config.ini pour ma base données et webacula.conf pour les acces et les rewrite et j'ai donné les droits au fichier pour bacula, jusqu'ici j'arrive a entrée dans l'interface mais l'affichage se fait sans utiliser les feuilles de style je pense et je n'est accès à aucun liens, ils me ramènent tous vers la page de login.
      1. Modérateur
        Comme je ne connais pas le produit et que je n'en ai pas trop besoin je ne sais pas trop quoi te dire. Je ne vois pas trop le rapport entre charger une feuille de style (regarde le code html tu verras bien) et le fais que tu sois loggué ou pas.
        1. Merci. c sympa quand même.
          Malgré tout g reussi. en faite j'avais un doublon sur un fichier de conf.
          Tout bete .
          1. Modérateur
            Ah oui là je ne pouvais pas deviner :p Ton problème est donc résolu ?
            1. oui resolu tout fonctionne correctement merci pour l'aide en tout cas