Excel/nb.si/entre deux dates. [Résolu/Fermé]

Signaler
Messages postés
738
Date d'inscription
samedi 22 mars 2008
Statut
Membre
Dernière intervention
4 janvier 2015
-
 Deckat -
bonsoir à tous et ttes,

dans mes cellules f1:f45, j'ai des dates aléatoires qui s'écoulent du 01/01/2009 au 01/01/2011.

j'aimerais compter le nombre de cellules dont la date est comprise entre le premier jour du trimestre et le dernier jour du trimestre.

pour ce faire je cherche une formule qui puisse calculer le nombre de cellule comprise entre deux dates.

en f46 je devrais donc avoir une formule qui calcule le nombre cellule comprise entre f1:f45 et dont la date est entre le 01/01/2009 et le 31/03/2009.
en f47, je devrais avoir une formule qui calcule le nombre cellule comprise entre f1:f45 et dont la date est entre le 01/04/2009 et le 30/06/2009.
en f48, je devrais avoir une formule qui calcule le nombre cellule comprise entre f1:f45 et dont la date est entre le 01/07/2009 et le 30/09/2009.
...

mon point de départ est la fonction nb.si. mais je n'arrive pas à ajouter la seconde date.

Je pensais faire comme ceci =nb.si(f1 :f45 ; « >=01/01/2009 » ; »<=31/03/2009 ») mais ça bugg...

Qq un pourrait-il m'aider en me mettant sur la piste....

Merci à vous...

Cdlmnt,

Berni//



4 réponses

Messages postés
738
Date d'inscription
samedi 22 mars 2008
Statut
Membre
Dernière intervention
4 janvier 2015
21
re-bsr vaucluse,

j'ai trouvé cette formule qui semble fonctionné...

=SOMMEPROD((F1:F7>="01/01/2010"*1)*(F1:F7<="31/03/2010"*1))

correct de ma part ou il y un buzz que j'ai pas compris...?

bine à vous

berni//
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57501 internautes nous ont dit merci ce mois-ci

Messages postés
25194
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 juillet 2020
5 378
bonjour Benjie

Correcte la deuxième,(surtout si elle fonctionne :-)) je n'avais pas en core tenté cette formulation!

je voulais simplement dire qu'à la place de "01/01/2010"*1, vous auriez pu mettre les dates dans une cellule et placer l'adresse des cellules dans la formule, mais puisque cela fonctionne comme ça.
Pour info, vous pouvez aussi remplacer "01/01/201°)*1 par DATEVAL("01/01/2010")
A priori c'st la même fonction et c'est bon à savoir.
Bonne journée
Crdlmnt
Bonjour Vaucluse,

J'ai le même soucis que Benji71.

La formule telle que décrite =SOMMEPROD((F1:F7>="01/01/2010"*1)*(F1:F7<="31/03/2010"*1)) fonctionne pour moi.

Mais en voulant appliquer votre réponse =SOMMEPROD((F1:F7>="C2")*(F1:F7<="D2")) par exemple, elle ne fonctionne plus.

A quel moment me trompes-je ?
> PoneyLanD
Bonjour,
il faut enlever les guillemets qui entoure votre case :

=SOMMEPROD((J9:J106>=B4*1)*(J9:J106<=B5*1))

cordialement
Messages postés
25194
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 juillet 2020
5 378
Bonsoir Benjie
Le plus simple est avec SOMMEPROD
pour travailler avec les dates, mieux vaut mettre les limites dans deux cellules
la formule:
=SOMMEPROD((Champ date<Cell maxi)*(Champ date>cell mini))
ce code n'incluant pas les limites.
pour les inclure, compléter avec >= ou<=
si vous ne mettez pas les dates limites dans une cellule, il faut placer leur valuer numérique dans la formule.

crdlmnt


Yes ca fonctionne Merci Bcp
Messages postés
738
Date d'inscription
samedi 22 mars 2008
Statut
Membre
Dernière intervention
4 janvier 2015
21
bonsoir cher vaucluse,

tjrs au poste...ça fait plaisir..merci à vous..

"pour travailler avec les dates, mieux vaut mettre les limites dans deux cellules"
vous voulez dire que je devrais mettre la date de début dans une cellule et la date de fin ds une autre cellule ?

sur une feuille d'essaie j'ai ecris ceci : =SOMMEPROD((F1:F7<=31/3/2010)*(F1:F7>=1/1/2010)) le résultat affciher est de 0 alors que j'ai au moins deux dates entre le 01/01/2010 et le 31/03/2010

n'ai donc pas compris qq chose..?

merci d'avoir la gentilesse d'éclairer ma lanterne... ;-)

bien à vous

berni//