Aide pour feuille de calcul heure excel [Résolu/Fermé]

Signaler
-
 le-belge-06 -
Bonsoir,

j'ai besoin d'aide pour completer ma feuille de calcule heure, sur 2 point

A- sur la 1er feuille, je suis a la recherche d'une formule pour calculer mes heure de nuit ( de 21H00 à 6H00 moin repos colonne E )

B- sur la 2 eme feuille en colonne G52 mon total n'est pas correcte, car j'ai des nombre en 2 format diffant : heure ( [h]:mm ) et decimale
j'ai essayer de modifier le format heure [h]:mm en ce format [h],mm et rien ne change

y a t'il une formule pour modifier mes heure en decimal
exemple: 20:30 en 20,50
20:45 en 20,75

merci

LIEN POUR MON FICHIER EXCEL http://www.cijoint.fr/cjlink.php?file=cj201012/cij5M471vx.xlsx



4 réponses

Messages postés
23703
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
1 décembre 2020
6 513
Bonsoir,

Sans tester car feuilles verrouillées...
1) =mod(D3-C3;1)-E3
2) =A1*24, mettre la cellule en format standard

eric
Bonsoir

merci pour l'info

pour deverouillée passe= azerty


je teste de suite

merci

ET NON SA NE FONCTIONE PAS
LE 1ER ME FAIT LE MEME CALCUL QUE LA COLONNE H
LE 2EME JE NE COMPREND PAS

MES GRAND MERCI
Messages postés
23703
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
1 décembre 2020
6 513
formules en L3 et M3
http://www.cijoint.fr/cjlink.php?file=cj201012/cijJdHj3GS.xls

eric

edit: je n'avais pas vu qu'il fallait limiter à la tranche 21h-6h, on verra ça demain...
bonjour

ok, j'ai compris pour le 2eme point
merci
Messages postés
23703
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
1 décembre 2020
6 513
Bonjour,

Si on suppose qu'il y a des heure des nuit si D3<C3 alors :
=SI(D3<C3;MOD((MIN(D3;"06:00")-MAX(C3;"21:00"));1)-E3;0)
Dis-moi si c'est ok

eric
PASSE POUR DEVEROUILLER = AZERTY
BONSOIR

SA FONCTIONE POUR LES 2 POINT

UN GRAND MERCI A TOI ERIC

http://www.cijoint.fr/cjlink.php?file=cj201012/cijb3QylRX.xls

POUR CELUI QUE SA VIENDRAIS INTERAISER, JE LE PAUFINE ET LE REMET EN LIEN PLUS TARD