Donner à une date la valeur 1 sur excel

Résolu/Fermé
Signaler
-
Messages postés
16537
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
25 novembre 2021
-
Bonjour,


Dans mon tableau excel j'ai des dates ex: 26/11/2010, 15/07/2010 et je voudrais dans une colonne à part faire correspondre une date à 1 et si pas de date = 0

Quelle est la formule?

Par avance, merci pour votre aide.

5 réponses

Messages postés
7395
Date d'inscription
vendredi 28 mars 2003
Statut
Contributeur
Dernière intervention
27 octobre 2020
3 169
salut
tu veux 1 si la cellule contenant la date n'est pas vide ou tu veux 1 uniquement si le contenu est une date et pas du texte ou autre ?
si j'ai une date dans ma case je veux que ça corresponde à 1 et si la cellule est vide je ne veux rien ou 0. Merci pour votre aide.
Messages postés
17686
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
29 novembre 2021
4 849
Salut,

Si ta valeur est en A1
cette formule et B1

=SI(ESTERREUR(DATEVAL(TEXTE(A1;"jj/mm/aa")));0;1)

et tu incrémentes vers le bas
super merci pour votre réponse rapide!
Messages postés
16537
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
25 novembre 2021
3 249
Bonjour

tout déprnd du format de ta date

si par exemple en A1
10/12/2010 ou 10/12/10
=(CELLULE("format";A1)="D1")*1

mais si format de date différent regarde l'aide à "cellule"

Michel
Messages postés
17686
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
29 novembre 2021
4 849
Re,

on pourrait tester le format de la cellule avec d'autres formules
comme

=SI(ET(A1>0;GAUCHE(CELLULE("format";A1))="D");1;0)

ou
=SI(GAUCHE(CELLULE("format";A1);1)="D";1;0)


A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
16537
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
25 novembre 2021
3 249
Bonjour,

Pourquoi utiliser un SI ?