Calcul ancienneté moyenne [Résolu/Fermé]

Signaler
-
Messages postés
51693
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 mai 2020
-
Bonjour,

En utilisant cette formule pour calculer l'ancienneté je me rends compte que je ne peux ensuite calculer l'ancienneté moyenne.

=DATEDIF(C11;AUJOURDHUI();"y") & " ans " & DATEDIF(C11;AUJOURDHUI();"ym") & " mois"

Quelqu'un aurait il une solution?


Merci

2 réponses

Messages postés
23761
Date d'inscription
dimanche 26 août 2001
Statut
Modérateur
Dernière intervention
13 janvier 2020
2 812
Salut,

et pourquoi tu ne peux pas ?
enh j'ai rien conprie du tout !!!!!!!!!!!!!!!! :(
Messages postés
51693
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 mai 2020
13 265
c'est pas grave ............. :-)
eh bien ça me met #DIV/0! quand je fais =MOYENNE(A1:G1)
Messages postés
23761
Date d'inscription
dimanche 26 août 2001
Statut
Modérateur
Dernière intervention
13 janvier 2020
2 812
C'est normal, tu crées une colonne avec une concaténation de champs.
Si tu veux faire une moyenne, il faut te créer une colonne avec le nombre de jours (=DATEDIF(C11;AUJOURDHUI();"d") ) faire ta moyenne et retransformer ce résultat en années/mois.
Euh... alors excuse moi mais qu'est ce qu'une concaténation? En fait il faut que j'ai 2 colonnes si je veux avoir dans une cellule ma moyenne et dans une colonne l'ancienneté de chaque personne?
Messages postés
23761
Date d'inscription
dimanche 26 août 2001
Statut
Modérateur
Dernière intervention
13 janvier 2020
2 812
Une concaténation, ça consiste à mettre des champs côte à côte.
Dans ton cas, il y a des informations qui ne peuvent faire partie d'un calcul (le nom 'mois', par exemple).
De plus, une moyenne se fait sur plusieurs cellules, mais n'offre qu'un seul résultat, donc je ne vois pas l'intérêt d'avoir une colonne 'moyenne' pour chaque ligne.
Messages postés
23392
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
25 mai 2020
6 154
Bonjour tout le monde,

Ce que veux te dire blux :
Il faudrait faire d'abord ta moyenne sur tes différences de dates (moyenne des simples soustraction des dates, ne pas utiliser datedif à ce moment), ce qui te donnera un résultat en jours.
Et ensuite faire datedif entre le '01/01/1900' et le '01/01/1900+ta_moyenne_en_jours' pour l'exprimer en années-mois

eric