Compter valeur identiques excel 2007 [Résolu/Fermé]

Signaler
-
 lazyvba -
Bonjour,

J'aurais voulu savoir si queqlqu'un pouvait m'aider.
J'ai un problème pour réaliser un histogramme.
J'ai mille valeur. Dans ces mille valeur certaines se répètent. J'aimerais savoir combien de fois chaque valeur se répète.
Et j'aimerais savoir comment faire ensuite un histogramme en fonction de chaque valeur et de son nombre d'occurence.

Merci beaucoup :-) !



3 réponses

Si si c'est bien ça ^^ !
Merci beaucoup !!!
hello,

J ai ecrit ce code pour repondre de maniere flexible et automatique au probleme du compte unique. c est du code vba a coller. J aimerais savoir si ca marche sur un excel a francais: si vous avez envie de tester.

http://lazyvba.blogspot.com/2010/11/improve-your-pivot-table-to-count.html

bonne journee
Bonjour

D'après ce que je comprends, si tes 1000 valeurs sont en colonne A par exemple, il te suffit d'ajouter en colonne B1 : =NB.SI($A$1:$A$1000;A1)
et de recopier la formule jusqu'en B1000, puis de sélectionner A1:B1000 et d'insérer un graphique. Les doublons ne seront pas pris en compte.

ça me semble trop simple, il doit y avoir autre chose ...