Samba et windows7 connexion impossible

[Résolu/Fermé]
Signaler
Messages postés
34
Date d'inscription
vendredi 18 avril 2008
Statut
Membre
Dernière intervention
16 novembre 2010
-
Messages postés
34
Date d'inscription
vendredi 18 avril 2008
Statut
Membre
Dernière intervention
16 novembre 2010
-
Bonjour,

cela fait maintenant quelques jours que j'essaye de me connecter sur mon Serveur Samba avec un PC Windows 7. Et j'ai toujours le même erreur: "Windows ne peut pas accéder à \\SAMBA". J'ai vraiment tout essayer sur ce qui est conseillé sur le net. A savoir, la modification des registres, l'upgrade de Samba à une version supérieur à 3.4. Bref j'ai tout essayé et j'ai toujours la même erreur.
Sur une machine XP la connexion se fait très bien. Le problème vient juste de la machine Seven. Si quelqu'un pourrait m'aider ce serai super sympa. Merci.


7 réponses

Messages postés
30193
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
15 octobre 2021
7 192
Ah vu que ça marchait avec XP (donc avec au moins un client), c'est clair que le serveur n'était pas en cause... et donc que c'était windows 7 (côté client) qui posait problème ! Merci pour les précisions que tu as apporté et bonne continuation !
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
34
Date d'inscription
vendredi 18 avril 2008
Statut
Membre
Dernière intervention
16 novembre 2010
6
J'ai trouvé ce que c'était. C'est le services "Assistance Netbios sur TCP/IP qui n'était pas démarré. Merci pour votre aide.
Messages postés
30193
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
15 octobre 2021
7 192
Ton serveur samba est bien sous linux ? Si oui quelle distribution utilises-tu ? Peux tu nous donner le contenu de /etc/samba/smb.conf ?
Messages postés
34
Date d'inscription
vendredi 18 avril 2008
Statut
Membre
Dernière intervention
16 novembre 2010
6
Oui mon serveur est bien sur Linux et j'utilise la distribution debian Lenny.

J'utilise SWAT pour configurer SAMBA.

Voici mon smb.conf:

# Samba config file created using SWAT
# from UNKNOWN (192.168.0.12)
# Date: 2010/11/15 20:08:08

[global]
server string = %h server
obey pam restrictions = Yes
pam password change = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
unix password sync = Yes
syslog = 0
log file = /var/log/samba/log.%m
max log size = 1000
dns proxy = No
panic action = /usr/share/samba/panic-action %d

[homes]
comment = Home Directories
valid users = %S
create mask = 0700
directory mask = 0700
browseable = No

[printers]
comment = All Printers
path = /var/spool/samba
create mask = 0700
printable = Yes
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/printers

Merci pour votre aide
Messages postés
30193
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
15 octobre 2021
7 192
Le service samba est lancé ?

service samba status


Le port associé à samba est visible ?

netstat -ntlp


Je ne vois rien dans ce fichier qui précise le nom du partage ni le chemin du partage côté linux (je ne sais plus si c'est dans ce fichier ou un autre), il n'est pas manquant dans le cas présent ?
http://doc.ubuntu-fr.org/samba#partager_un_dossier_du_systeme_de_fichiers_shares

Bonne chance
Messages postés
34
Date d'inscription
vendredi 18 avril 2008
Statut
Membre
Dernière intervention
16 novembre 2010
6
Oui le service Samba est bien lancé vu que j'y accède depuis Windows XP.
Le problème est que je n'y arrive pas à me connecter depuis SEVEN. Je ne sais vraiment pas d'ou peut venir l'erreur.

Je vais essayer ce que vous m'avez envoyer et l'essayer.

Merci pour votre aide.
Messages postés
34
Date d'inscription
vendredi 18 avril 2008
Statut
Membre
Dernière intervention
16 novembre 2010
6
Merci à toi pour ton aide