Excel - Résultat = Référence cellule

[Résolu/Fermé]
Signaler
-
 Céline -
Bonjour,

Je cherche à faire entrer la valeur d'une cellule dans une formule.
Je m'explique : je fais un calcul de semaine par rapport à une date donnée (=(maintenant - J0)/7) et je voudrais faire un calcul d'avancement grâce à ce calcul. Si on a commencé la tache depuis 2 semaines ma première formule me donne 2, je voudrais qu'un autre cacul se fasse depuis une cellule fixe (ex :LC) jusqu'à une autre (LC2), le 2 de cette référence étant le résultat de l'autre formule.


3 réponses

Messages postés
12257
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
3 septembre 2021
2 652
Bonjour,
On peux tout d'abord essayer un petit test?

En colonne A, de A1 à A10 saisis des 1.
En B1 un chiffre quelconque (entre 1 et 10)
En C1 écris cette formule : =SOMME(A1:DECALER(A1;B1-1;0;;))
Puis change la valeur de B1.

Est ce que cela corresponds à tes attentes?

Si oui qu'elles sont les formules utilisées? (afin que nous puissions peut être les adapter...)
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

c'est tout à fait ça ! J'ai juste dû adapter car mes valeurs sont sur une meme ligne et pas sur une meme colonne mais ca marche nickel !
Maintenant je l'ai testé sur Excel 2007, j'espère que ca fonctionnera sur mon vieux Excel 2000 !
Messages postés
822
Date d'inscription
mercredi 15 octobre 2008
Statut
Membre
Dernière intervention
8 octobre 2011
183
bonjour;
si j'ai bien comprit votre problème:
=(NB.JOURS.OUVRES(DATE1;DATE2)/7)
Ca c'est (presque) ma première formule effectivement, mais ce dont j'ai besoin c'est que le resultat de cette formule me permette d'etre entré dans une autre :
=(date2-date1)/7 si le resultat est = 2
autre formule :
=SOMME(LC1:L1C(-2))
Le "2" de cette formule étant le résultat du premier calcul
Messages postés
822
Date d'inscription
mercredi 15 octobre 2008
Statut
Membre
Dernière intervention
8 octobre 2011
183
=SI((NB.JOURS.OUVRES(DATE1;DATE2)/7)=2;SOMME(LC1:L1C(-2)) ;" ")
Le problème c'est qu'il faudrait que je crée une condition "SI" pour chaque valeur possible de la première formule ....
mais effectivement ca marche.