Tableau excel

Fermé
Signaler
-
Messages postés
12257
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
3 septembre 2021
-
Bonjour,

Je suis en train de faire sur excel un tableau pour mon entreprise mais j'ai quelques difficultés.

Je m'explique avec un exemple :

1ere colonne "date" : 31/12
2 eme colonne "etats" : A jour ou A demander

En fait je voudrais savoir comment je dois faire que le message "a jour" ou " a demander" apparaisse 4 mois apres.

Je m'explique :

Par exemple pour le cas du 31/12, je voudrai que entre le 01/04 et le 30/04 le message "a demander" apparaisse et pour le reste de l'année je voudrai qu'il apparaisse "a jour".

Pouvez vous m'aider svp?

Merci d'avance

3 réponses

Messages postés
12257
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
3 septembre 2021
2 667
Bonjour,
Votre 1ère date en A1, en B1 inscrivez :
=SI(ET(AUJOURDHUI()>DATE(ANNEE(A1);(MOIS(A1)+3);JOUR(A1));AUJOURDHUI()<DATE(ANNEE(A1);(MOIS(A1)+4);JOUR(A1)));"à demander";"à jour")

Formule que vous "tirez" ensuite vers le bas colonne B.

Cordialement,
-- Il n'y a rien de tel qu'une question idiote, seulement une réponse idiote. A.Einstein --
Messages postés
26310
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 décembre 2021
6 131
Bonjour
le plus simple est de ne pas tenir compte des mois, mais d'une moyenne jour par mois que l'on peut compter à 120 jours pour 4 mois:
en 1 à tirer sur la hauteur
=SI(A1=0;"";SI(AUJOURDHUI()>A1+120);"à jour";"à demander"))

crdlmnt

Excel me dit que la formule contient une erreur
Messages postés
26310
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 décembre 2021
6 131
Exact, mea-culpa, (taper trop vite), il faut supprimer la parenthèse après 120
avec mes excuses

Ca marche.

Merci de votre aide

Cdt
Est ce que vous sauriez y introduire une intervalle?

Pour que ma valeur soit comprise entre 90 et 120 et non > à 120.

Merci d'avance
Messages postés
12257
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
3 septembre 2021
2 667
Salut,
Bonjour Vaucluse,
En adaptant la formule de Vaucluse et la mienne...
=SI(A1=0;"";SI(ET(AUJOURDHUI()<A1+120;AUJOURDHUI()>A1+90);"à jour";"à demander"))

Merci pour vos réponses rapides.

Cdt