Excel: forcer affichage date ou nombre [Résolu/Fermé]

Signaler
-
 freemric -
Bonjour,

je voudrais savoir s'il est possible d'afficher dans une cellule qui est le résultat d'une fonction soit une date soit un nombre.
par exemple: colonne A = recherchev sur une date.
colonne B = nombre
ma formule est =SI(ESTERREUR(a1;b1;a1))
le résultat est tjs un nombre ou une date alors que je voudrais forcer le format d'affichage selon la colonne recherchée (du type estdate/ endate)

merci d'avance de vos lumières

3 réponses

Messages postés
16436
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
21 avril 2021
3 164
Bonjour à tous
sur cette formule la date est dans A2 à adapter au cas réel
essaies:
=SI(ESTERREUR(A1);TEXTE(B1;"######")*1;TEXTE(A2;"jj/mm/AA")) 

la date est en format texte; le nombre est en format nombre
Michel
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
25987
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 avril 2021
5 885
Bonjour
avec la mise e'n forme conditionnelle, sans doute:
Formatez la colonne en Date
mise en forme conditionnelle sur la colonne:
la formule est:
=B1=xxx
xxx étant la condition qui fait que B1 est un nombre
formatez format nombre ou standard
quand la condition sera remplie, le format de cellule sera en num, sinon en date.
Crdlmnt


merci beaucoup pour la réponse et sa rapidité. mon boss va être content (tout comme moi). je ne connaissais pas la formule Texte qui permet de définir le type d'affichage du texte. je sens que je vais l'utiliser pas mal à l'avenir.