Excel convertir une date en texte [Fermé]

Signaler
Messages postés
4
Date d'inscription
mercredi 29 septembre 2010
Statut
Membre
Dernière intervention
4 octobre 2010
-
Messages postés
4
Date d'inscription
mercredi 29 septembre 2010
Statut
Membre
Dernière intervention
4 octobre 2010
-
Bonjour,


Comment faire pour converti une date au format cellule "jjjj" ex : 01/01/10 = samedi
au format texte "@" et avoir samedi pour concatener : Samedi - Dimanche -.....
Merci

4 réponses

Messages postés
579
Date d'inscription
mardi 10 août 2010
Statut
Membre
Dernière intervention
11 novembre 2018
288
Bonjour,

2 autres méthodes :

La plus simple, si date dans cellule A1, en B1, mettre =A1, format de la cellule : "jjjj"

2ème :

=TEXTE(A1;"jjjj")


Par contre, je ne comprends pas ta 2ème question à propos des "Samedi-dimanche"?????

Bon dimanche
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
25378
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2020
5 526
Bonjour
une solution (même si ça n'est peut être pas la meilleure), pour extraire en texte le jour d'une date:
hors champ ou sur une feuille masquée:
créer un tabeau avec de A1 à A7: les nombres de 1 à7
de B1 à B7 les jours de la semaine en texte, en commençant par dimanche
nommer ce champ pour l'exemple :JOUR
revenz da,ns votre tableau et pour obtenir le jour dans la formule de concaténation:
RECHERCHEV(JOURSEM(Cellule date); JOUR;2;0)
à inclure dans la concaténation ou à placer dans une cellule.
Crdlmnt
Messages postés
4
Date d'inscription
mercredi 29 septembre 2010
Statut
Membre
Dernière intervention
4 octobre 2010

Bonjour,
Je vous remercie pour vos réponses mais se n'est pas ce que je cherche, c'est plus compliqué que ça, la solution la plus appropriée je pense qu'il faut créer une petite macro où l'on trouve :
la date insérée A1 : (01/01/2011)
A2 : format cellule "jjjj" (Vendredi)
B1 : copiez A2, Collez valeur dans B1
ainsi je retrouve ma journée (vendredi) en texte et je pourais la concatener.

mais je pensais qu'il pouvait y avoir une formule ou une fonction pour ça
Merci
Messages postés
25378
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2020
5 526
Re
Curieux, je viens de tester et la formule TEXTE de Cousinhub permet bien la concaténation? Il s'agit d'une formule pas d'un format, on est bien d'accord (sa 2° proposition)?
crdlmnt
Messages postés
25378
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2020
5 526
pour compléter message ci dessus voici ce que donne directement la proposition de Cousinhub. Si ce n'est pas ça que vous souhaitez, revenez avec plus de précisions!
http://www.cijoint.fr/cjlink.php?file=cj201010/cij6DybVpq.xls
Messages postés
4
Date d'inscription
mercredi 29 septembre 2010
Statut
Membre
Dernière intervention
4 octobre 2010

Bonjour,
Je vous remercie Vaucluse & Cousinhub pour votre aide, c'est bon j'arrive à le faire.