Excel 2003 : formule "gauche()"

[Résolu/Fermé]
Signaler
-
 Lancelot -
Bonjour,

J'ai une colonne avec des données du type : 4 chiffres texte. (0245 systeme proprio). Je voudrais taper dans une autre colonne =gauche(C9;4) et de tirer vers le bas. Cela marche pour la première cellule qui affiche bien les 4 symboles de la cellule cible. Le problème est que quand je tire, je ne fais que copier la valeur de la première cellule.

Savez-vous comment appliquer la formule pour toute la collone. Merci beaucoup.



3 réponses

Messages postés
7395
Date d'inscription
vendredi 28 mars 2003
Statut
Contributeur
Dernière intervention
27 octobre 2020
3 155
Salut
1- dans ta formule c'est bien C9 et pas $C$9 ?
2- pour tirer ta formule vers le bas tu mets bien ton curseur sur l'angle inférieur droit de ta cellule, il change de forme et devient une + ?
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

1. C'est bien C9.
2. Oui.

J'utilise excel quotidiennement. J'ai jamais vu ça.

Exemple :
7012 MAXIMAL AU TX NORMAL
0410 ASTREINTE

Je tape "=gauche(C9;4) et j'obtiens 7012. Je copie la formule sur la cellule au dessous et au lieu de 0410, j'obtiens 7012 de nouveau.
Messages postés
1823
Date d'inscription
vendredi 5 septembre 2008
Statut
Contributeur
Dernière intervention
24 avril 2020
623
Bonjour,

Une idée à essayer : Il se peut que les formules "ne suivent pas" selon l'option choisie.

Aller dans le menu "Outils" puis "Options"
Dans l'onglet "Modification" il y a une case à cocher qui s'intitule :
"Etendre les formules et formats de plages de données" elle doit être décochée, il faut la cocher

A +

EDIT : Non désolé j'ai mal lue la demande et j'ai répondu à coté !!!
Cordialement,
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
1823
Date d'inscription
vendredi 5 septembre 2008
Statut
Contributeur
Dernière intervention
24 avril 2020
623
Une autre idée du même type vérifier dans les options si le mode de calcul est bien automatique:

Voir toujours dans "Outils" puis "Options" dans l'onglet "Calcul" voir si l'option est bien sur "Auomatique" et non pas sur "sur ordre"
Merci beaucoup à tous pour vos réponses. Le problème s'est résolu quand j'ai sauvegardé le fichier. Je n'ai pas compris pourquoi sur le coup mais maintenant grâce à votre commentaire j'ai compris.
Dans Outils-Options-Calculs l'option automatique n'était pas coché, j'étais sur "sur ordre" et "Recalcul avec l'enregistrement".
Messages postés
7395
Date d'inscription
vendredi 28 mars 2003
Statut
Contributeur
Dernière intervention
27 octobre 2020
3 155
et en appuyant sur la touche Ctrl pendant la recopie vers le bas ?
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci