Formule excel sommeprod matriciel peut être

Résolu/Fermé
Signaler
-
Messages postés
2967
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
-
Bonjour,

Voici mon problème :

J'ai en colonne A, des noms (dont certains peuvent être identiques).
J'ai en colonne B et C des nombres.

Je recherche la formule permettant de me sortir le nom tel que la somme des produits des colonnes B et C soit supérieur à celle de tous les autres noms.

Un petit exemple :

Antoine | 5 | 1
Marie | 3 | 2
Pierre | 4 | 4
Antoine | 3 | 3
Marie | 1 | 1
Luc | 9 | 1

Ici, je cherche donc à avoir "Pierre", puisque Pierre totalise 16, Marie 7, Antoine 14 et Luc 9.

Merci de votre aide,
gobman007

5 réponses

Messages postés
26318
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 décembre 2021
6 135
petite question
qu'appeler vous somme des produits?
comment trouve t'on 16 avec 4 et 4 (ça ça va) et 7 avec 3 et 2 ou 14 avec 3 et 3?
etc....
crdlmnt
Messages postés
600
Date d'inscription
dimanche 8 novembre 2009
Statut
Membre
Dernière intervention
21 juin 2015
245
en colonne D
=B:B*C:C

en colonne E
=SOMME.SI(A:A;A:A;D:D)
---------------------------------------------------------------

pour répondre exactement à la question, il faudrait insérer 3 colonnes
(pour faire un rechecheV)

colonne A:
=E:E*F:F

colonne B:
=SOMME.SI(D:D;D:D;A:A)

cellule C1: (résultat)
=RECHERCHEV(MAX($B:$B);$B:$D;3;0)

colonne D:
prénoms

colonne E et F:
les chiffres

Attention!!! si des résultats sont identiques, seul le premier de la liste apparaitra.
Merci tchernosplif !

Ca marche parfaitement ... et y a-t-il une façon de faire sans utiliser des colonnes supplémentaires ?
ok ... merci :) !!
Messages postés
2967
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
891
Salut le forum

Avec seulement une colonne intermédiaire

Noms en A2:A7
Valeurs en B2:B7 et C2:C7

Colonne Intermédiare :
En D2 = B2 * C2 (à recopier vers le bas)

Nom pour le plus gros total : (Formule matricielle, à valider par Ctrl+Shift+Enter)
=INDEX(A2:A7;EQUIV(MAX(SOMME.SI(A2:A7;A2:A7;D2:D7));SOMME.SI(A2:A7;A2:A7;D2:D7);0))

Mytå
Merci de donner suite à votre question, nous ne sommes pas des robots...
Versions installées [MsProject 2003(FR), Excel 2003-2007(FR)]