Excel fonction SI a plusieurs critères [Résolu/Fermé]

Signaler
Messages postés
44
Date d'inscription
mercredi 23 septembre 2009
Statut
Membre
Dernière intervention
31 janvier 2017
-
Messages postés
8348
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
16 janvier 2021
-
Bonjour à tous,

Voila, je cherche a faire une fonction a plusieurs critères et plusieurs résultats.
En gros :

Dans la cellule A1 je dois mettre une croix ou non
Dans la cellule B1 je dois mettre une croix aussi ou non.

Dans la cellule C1 je veux que s'affiche automatiquement le chiffre qui est dans D1 si A1 a une croix et que B1 n'en a pas.

Si A1 et B1 ont une croix, alors c'est le chiffre de E1 + F1 qui s'affichera dans C1.

Si aucune croix n'est dans A1 et B1 alors C1 = 0.

Je sais que il doit y avoir une solution en combinant le SI avec le ET et le OU. mais j'ai mal au crane de chercher ca depuis hier matin.

Pouvez vous m'aider s'il vous plait?

Merci de vos réponses.

Excel2007


4 réponses

Messages postés
9978
Date d'inscription
mercredi 22 août 2007
Statut
Contributeur
Dernière intervention
28 décembre 2019
1 753
Salut que doit il se passer quand A1 n'a pas de croix et que B1 en a une?
Messages postés
8348
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
16 janvier 2021
1 567
Bonjour

essaie :
=SI(A1="x";SI(B1="x";E1+F1;D1);0)

mais la question de Xvarstrablues reste entière, avec cette formule, quand il n'y a pas de croix en A1 et qu'il y en a pas en B1, le résultat sera 0

Patrice
Messages postés
44
Date d'inscription
mercredi 23 septembre 2009
Statut
Membre
Dernière intervention
31 janvier 2017
1
Salut Xav et patrice
Merci pour vos réponses.

Si B1 a une croix et que A1 n'en a pas alors C1=0

Patrice je vais essayer ca et je te dirai si ca marche.
Messages postés
44
Date d'inscription
mercredi 23 septembre 2009
Statut
Membre
Dernière intervention
31 janvier 2017
1
Je me rend compte en essayant d'appliquer ta formule Patrice, que je n'ai pas été très clair sur les critère mais je pense avoir finit par trouvé la solution.

Voici en gros ce que j'avais besoin sous forme de tableur test.

http://www.cijoint.fr/cjlink.php?file=cj201009/cijbrSUdtZ.xls

j'ai de bon résultats sur mon tableur final.

Merci a vous en tout cas car c'est en voulant vous redonner les criteres que j'ai finit par trouvé en voulant simplifier au mieux :).
Messages postés
8348
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
16 janvier 2021
1 567
De rien, au plaisir