Excel/recherche dans tableau/prix

Résolu/Fermé
benji71
Messages postés
738
Date d'inscription
samedi 22 mars 2008
Statut
Membre
Dernière intervention
4 janvier 2015
- 12 août 2010 à 08:56
Mytå
Messages postés
2967
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
- 15 août 2010 à 20:09
bonjour à tous et toutes,

Dans un classeurs, J'ai deux feuilles : la première tableau revenus, la seconde dénomée pfp 2010 .

La premier feuille contient en A5 :F143 un tableau divisé en 6 colonnes et 143 lignes de chiffres.

Les deux premières colonnes contiennent les revenus d'un ménage. La colonne 1 contient un revenu minimum et la colonne 2 un revenue maximum.
Dans les colonnes C et E il y un montant qui représente ce qui pourrait être réclamé comme intervention financière.

Les colonnes D et F il y un montant qui représente ce qui pourrait être réclamé comme intervention financière tenant compte du nombre de personnes dans le ménage.

Dans la second feuille, j'ai en a2 les revenus du ménages. J'aimerai qu'en b2 et c2 vienne s'inscrire combien les parents vont-ils payer sur bases de leurs revenus.

Exemple, si des parents gagnent ensemble 2500 euro, va venir s'inscrire dans les cellules de la feuille pfp, le montant qu'ils devraient payer.

Ma question est : est-il possible que sur base du revenu indiqué dans la cellules a2 de la feuille dénommée pfp, il puisse venir s'inscrire l'intervention financière que les parents pourraient être amené à payer. Si oui, pouvez me donner quelque indication sur le comment faire.

une piste pourrait-elle d'aller voir du côté d'index recherche ?

A toute fin utile, je joins le fichier.

Merci de vos éclairages et conseils.


http://www.cijoint.fr/cjlink.php?file=cj201008/cij8d3t1xI.xls

13 réponses

Mytå
Messages postés
2967
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
905
15 août 2010 à 20:00
Re le forum

Modifie ta condition de test

En colonne U et W
OU($S3="";$S3=0;$T3="X")

En colonne V et X
OU($S3="";$S3=0;$T3<>"X")

Mytå
1
pijaku
Messages postés
12257
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
3 septembre 2021
2 695
12 août 2010 à 09:17
Bonjour,
La fonction RECHERCHEV(valeur_cherchée;matrice;N° Colonne;Valeur proche) SI ET SEULEMENT SI Valeur proche = VRAI, va rechercher dans ta matrice, la valeur approchante strictement inférieure (puisque l'on parle de nombres) à celle de ta valeur cherchée.
La formule à appliquer (en Feuil1, cellule B2) est donc :
=RECHERCHEV(A2;'2010'!B5:G143;3;VRAI)
voici ton classeur en retour
Tu nous dis...
0
benji71
Messages postés
738
Date d'inscription
samedi 22 mars 2008
Statut
Membre
Dernière intervention
4 janvier 2015
25
12 août 2010 à 10:56
"il est tres fort...."

Bonjour pijaku,


le texte ci-dessus t'es adressé :-)

petite question subsidaire, si j'ajoute une colonne dans laquelle je viens mettre une croix pour signifier que les parents ont trois enfants et donc qu'il paieront 70 % du prix c'est possible ?

exemple si j'insere une colonne entre les colonnes a et b dans laquelle je viens mettre une croix en cas de prix 70 % est-il possible que les colonnes b et d actuelle n'apparaissent pas ?

l'idée est de n'avoir que deux montant soit 100 %, soit 70 %

merci à toi.

cordialement.

berni/
0
benji71
Messages postés
738
Date d'inscription
samedi 22 mars 2008
Statut
Membre
Dernière intervention
4 janvier 2015
25
12 août 2010 à 11:01
voici le fichier modifier avec la colonne en plus.

http://www.cijoint.fr/cjlink.php?file=cj201008/cijDvN5b6k.xls

bien à toi.

berni/
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
pijaku
Messages postés
12257
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
3 septembre 2021
2 695
12 août 2010 à 11:09
Non pas très fort, je t'assure.
Sans problème, il suffit de tester si en B3 on trouve un "x". Simple condition SI : SI(B3=x;alors en col 100 rien;sinon résultat de la recherche) ce qui se trazduit en Excel par :
Colonne 100% :
=SI(B3="x";"";RECHERCHEV(A3;'2010'!B5:G143;3;VRAI))
Colonne 70% :
=SI(B3="x";RECHERCHEV(A3;'2010'!B5:G143;4;VRAI);"")

ton classeur complété en retour

0
benji71
Messages postés
738
Date d'inscription
samedi 22 mars 2008
Statut
Membre
Dernière intervention
4 janvier 2015
25
15 août 2010 à 14:35
Bonjour pijaku,

tite question supplémentaire.

la formule indique que si : =SI(B3="x";"";RECHERCHEV(A3;'2010'!B5:G143;3;VRAI)).

cela suppose que j'ai qq chose en a3 mais si j'ai pas de revenu en a3 comme tu t'en doute, il m'indique...#N/A...

j'ai cherché en essayant ceci : =si(et(..... mais sans résultat... ou je l'ai pas bien fait...cela donnait ceci. : =si(et(a3="";"");B3="x";"";RECHERCHEV(A3;'2010'!B5:G143;3;VRAI))

ça marche pas..

as-tu une piste pour moi ?

merci à toi.

berni/
0
pijaku
Messages postés
12257
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
3 septembre 2021
2 695
15 août 2010 à 16:05
Salut,
=SI(OU(A3="";B3="X");"";RECHERCHEV(A3;'2010'!B5:G143;3;VRAI))
Devrait te donner ton résultat...
0
benji71
Messages postés
738
Date d'inscription
samedi 22 mars 2008
Statut
Membre
Dernière intervention
4 janvier 2015
25
15 août 2010 à 17:11
re-bjr pijaku,

au risque de te parraître ennuyant..il apparait qu'il reste qq soucis.

voici le fichier avec la formule proposée et adapté :

http://www.cijoint.fr/cjlink.php?file=cj201008/cij1T2Yxtl.xls

la finalité du résultat devrait être que si en s3 il n'y à rien alors dans les cellules u3:x3 rien ne devrait apparaître alors que pour le moment j'ai #N/A qui s'inscrit

second constat, si j'ai qq chose en s3, et que je met une x en t3 devrait s'affciher les 70 % mais visiblement là non plus cela marche pas...

j'ai essayer de chipoter mais je trouve pas la bonne formule.

derniere chose peux-tu me dire la focntion du chiffre 3 avant le vrai dans la formule (=SI(OU(V3="";W3="X");"";RECHERCHEV(V3;'2010'!E5:J143;3;VRAI))

merci de ta patience et de ton éclairage.

bien à toi

Berni/
0
pijaku
Messages postés
12257
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
3 septembre 2021
2 695
Modifié par pijaku le 15/08/2010 à 17:36
[https://www.cjoint.com/?iprJy2UrxM voici ton fichier. ]
J'ai utilisé des $ pour bloquer les colonnes pour la recopie de la formule...
Le 3 veux dire 3ème colonne à droite de la colonne de recherche
0
benji71
Messages postés
738
Date d'inscription
samedi 22 mars 2008
Statut
Membre
Dernière intervention
4 janvier 2015
25
15 août 2010 à 18:18
re-pijaku,

ai big problème...si je tape la somme de 924 dans la cellule s3 dans la cellule 100 % il me donne 924,39 alors qu'il devrait m'indiquer 3, 80 pour une journée complete et 2,28 pour une demi journée...

autre big souci, si je met une croix dans la cellule t3, ilne m'indique plus les 70 % mais tout est vide...

je t'assure que j'essai d'y mettre du mien mais je comprends pas...

help...

merci de ton aide...

berni/
0
Mytå
Messages postés
2967
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
905
Modifié par Mytå le 15/08/2010 à 19:17
salut le forum

Tu veux récupérer la 3ième colonne (Colonne D)

«Si l'argument no_index_col est égal à 1, la fonction renvoie la valeur dans
la première colonne de l'argument table_matrice ; si l'argument no_index_col
est égal à 2, la valeur est renvoyée dans la deuxième colonne de l'argument
table_matrice, et ainsi de suite.»

=SI(OU($S3="";$S3=0;$T3="X");"";RECHERCHEV($S3;'2010'!$B$5:$G$143;3;VRAI))

Mytå
Merci de donner suite à votre question, nous ne sommes pas des robots...
Versions installées [MsProject 2003(FR), Excel 2003-2007(FR)]
0
benji71
Messages postés
738
Date d'inscription
samedi 22 mars 2008
Statut
Membre
Dernière intervention
4 janvier 2015
25
15 août 2010 à 19:33
Bonjour myta;

merci de ton aide et ton intervention, je me permets de remettre le fichier en ligne afin que tu puisses essayer car même si pijaku fait preuve de bcp de patience, pour le moment, je rame un peu.

http://www.cijoint.fr/cjlink.php?file=cj201008/cijdXu9N3T.xls

merci de ton aide.

pour rappel : le résultat de la cellule s3 doit me donner u3 et w3 le montant de l'intervention financière. et si il y a une x en t3 c'est dans la cellules v3 et x3 que doit apparaitre le montant.

le montant de l'inteventin financière étant à trouver sur la feuille 2010. la difficulté etant qu'excel trouve le montant entre les deux sommes des colonnes b et c de la feuille 2010 et puis indique le montant de l'intervention dans les bonnes cellules à droite.

autre difficulté, s'il n'y à rien en s3, je ne devrait rien voir apparaître dans les cellules u3:x3.

je suis un peu chiant mais....de mon côté j'essai aussi...

merci de votre aide.

berni/
0
Mytå
Messages postés
2967
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
905
15 août 2010 à 19:42
Re le forum

Benji, tu fais pas attention aux formules

En U3 c'est OK
=SI(OU($S3="";$S3=0;$T3="X");"";RECHERCHEV($S3;'2010'!$B$5:$G$143;3;VRAI))

En V3 tu fais une erreur, tu recherches en colonne C
=SI(OU($S3="";$S3=0;$T3="X");"";RECHERCHEV($S3;'2010'!$C$5:$H$143;3;VRAI))

La bonne formule
=SI(OU($S3="";$S3=0;$T3="X");"";RECHERCHEV($S3;'2010'!$B$5:$G$143;4;VRAI))

Adapte les autres c'est la même problématique

Mytå
0
benji71
Messages postés
738
Date d'inscription
samedi 22 mars 2008
Statut
Membre
Dernière intervention
4 janvier 2015
25
15 août 2010 à 19:54
re-bsr myta,

sorry pour l'erreur...j'avoue avoir la tête dans c... avec un grippe..et oui le 15 août avoir la grippe j'aurai tt eu...

dernier chose, tu auras constaté que si je met un x dans la cellule t3 ne il ne devrait plus s'afficher que les cellules avec 70 % et inversement s'il n'y a rien dans la cellules t3 seule cellules 100 % devrait s'afficher...

actuellement, si je met un x dans la cellule t3 les cellules u3:x3 il n'y à plus rien qui apparait...

une piste de solution pour moi ?

cordialement et grippalement...

berni/
0
benji71
Messages postés
738
Date d'inscription
samedi 22 mars 2008
Statut
Membre
Dernière intervention
4 janvier 2015
25
15 août 2010 à 20:06
SUPER cela marche....merci myta....je n'oubli pas pijaku pour son aide également..voila qq chose de régler. merci à toi, à vous.

cordialement.

berni/
0
Mytå
Messages postés
2967
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
905
15 août 2010 à 20:09
Re le forum

Problème résolu, à la prochaine !

Mytå
0