Activer la carte réseau

[Résolu/Fermé]
Signaler
-
Messages postés
1
Date d'inscription
mardi 11 août 2009
Statut
Membre
Dernière intervention
11 août 2009
-
bonjour a tous,
après avoir checker plusieurs post sans succes, je poste ici un pb qui a déjà été soulevé mais je n'ai pas trouver ma réponse.

j'ai compiler un nouveau noyau, après sa compilation ma carte réseau n'est plus active. j'ai pourtant bien ajouter le driver de cette carte en alias dans le fichier /etc/modules.conf; j'ai bien essayer de faire un modprobe de ce driver, de la carte, un ifup de eth0...

Sans SUCCES! il ne reconnait pas la carte réseau...Voici le message:
Eth0: Error while getting interface flags: No such device


quand je reboot sur mon ancien noyau, il n'y a pas de pb! Comment faire?

3 réponses

Messages postés
1
Date d'inscription
mardi 11 août 2009
Statut
Membre
Dernière intervention
11 août 2009
2
bonjour cava
j aiun problem la
je veux partager mon connection adsl vers 2 PC ??
et aussi je veux savoir est ce que ma car reseus est activer ?? et merci cest mon premiere participer dans cette site et mercii
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci


j'ai acheté un ordinateur Imac. Ce modèle peut recevoir MAC OS léopard et aussi on peut y configurer windows.
J'ai donc configurer windows vista que j'ai activé.
Le problème est que je n'arrive pas à me connecter sur internet.
Mon serveur me dit que tout est correct de son côté, et il précise que je dois avoir une carte réseau pour avoir le pilote nécessaire pour me connecter à internet !!!
Je ne comprends pas, faut-il que je télécharge une telle carte ? Si oui, où puis-je trouver ce téléchargement ?
Et ensuite que dois-je faire ?
merci
Messages postés
1564
Date d'inscription
mercredi 30 mars 2005
Statut
Contributeur
Dernière intervention
22 juin 2007
494
Si ton nouveau noyau est un 2.6 ce n'est plus /etc/modules.conf (comme pour 2.4) mais /etc/modprobe.conf.

Peut-etre tu n'as pas compile le bon module avec le nouveau noyau (un oublie dans la config dans "make xconfig" ou "make menuconfig") ?
Regarde dans /lib/module/<numero_version_noyau>/kernel/drivers/net/... si tu y trouves un fichier *.o ou *.ko (ou *.ko.gz si c'est compresse) avec le nom de ton module. Compare ce repertoire pour l'ancien et nouveau noyau.

Si tu as fait un passage d'un noyau 2.4 vers 2.6 il est possible que le nom du driver a change. Il faut tres soigneusement lire le blabla-help dans "make xconfig" pour trouver ta carte et le bon nom.

Apart ca un petit detail: Apres tout changement de /etc/modules.conf (pour un noyau 2.4) ou /etc/modprobe.conf (pour un noyau 2.6) il faut faire "/sbin/depmod -a" pour mettre a jour la base de donnees pour les modules.