[Excel] Attribuer valeur à texte de liste dér

[Résolu/Fermé]
Signaler
Messages postés
6
Date d'inscription
mercredi 2 décembre 2009
Statut
Membre
Dernière intervention
15 mars 2011
-
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
-
Bonjour à tous,

Je crée un fichier excel avec une liste déroulante avec 4 choix.
Je souhaiterais effectuer un calcul dans une autre colonne où chaque choix de ma liste déroulante correspondrait à une valeur.
Ma liste déroulante est composée des choix : plein, trois quart plein, à moitié plein et trois quart vide.
Je voudrais, dans une autre colonne, effectuer un calcul avec si le choix de la liste déroulante est plein, la valeur utilisée dans le calcul sera 1, si le choix est trois quart plein la valeur sera 0,75 etc....

Merci d'avance pour vos réponses.


Cdt




3 réponses

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 523
bonjour

Pour obtenir la valeur utilisée dans ton calcul tu peux utiliser (avec ton choix en A1) cette formule :

=CHOISIR(EQUIV(A1;{"plein";"trois quart plein";"à moitié plein";"trois quart vide"};0);1;0,75;0,5;0,25)

Tu peux bien sûr "tirer" cette formule sur ta colonne ou nommer ta formule pour simplifier tes formules de calcul.
6
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
10461
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
12 octobre 2021
1 213
Bonjour gbinforme,
Celle là je la pique au passage.
Merci.
Salutations.
Le Pingou
bonjour, serait il possible de la faire en Anglais please ?
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 523
Il faut aussi utiliser lesoutils à disposition ;-)
Messages postés
10461
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
12 octobre 2021
1 213
Bonjour,
Au passage, en A1 la liste déroulante, en B1 la valeur de base et en C1 la formule:
=SI(A1="";"";SI(A1="plein";B1*1;SI(A1="trois quart plein";B1*0.75;SI(A1="à moitié plein";B1*0.5;B1*0.25)))) 

Salutations.
Le Pingou
Messages postés
6
Date d'inscription
mercredi 2 décembre 2009
Statut
Membre
Dernière intervention
15 mars 2011

Merci à tous les deux pour votre rapidité, ca marche nickel!!

Slts