Excel: nombre positif en nombre négatif [Résolu/Fermé]

Signaler
Messages postés
9
Date d'inscription
jeudi 1 juillet 2010
Statut
Membre
Dernière intervention
15 juillet 2010
-
Messages postés
9
Date d'inscription
jeudi 1 juillet 2010
Statut
Membre
Dernière intervention
15 juillet 2010
-
Bonjour,

Une colonne contient des nombres et leur somme.


A1 = 100
A2 = 300
A4 = 250
A5 = somme de A1:A4

Comment faire une conition pour que :

Si dans B1 il est ecrit "A" le nombre dans A1 reste positif

Si dans B1 il est écrit "S" le nombre dans A1 devient négatif


La même chose pour les autres lignes.


Merci !

1 réponse

Messages postés
2966
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
809
Salut le forum

Au-lieu d'utiliser =Somme("A1:A3")

Utilise =SOMME.SI(B1:B3;"A";A1:A3)-SOMME.SI(B1:B3;"S";A1:A3)
Mytå
Messages postés
9
Date d'inscription
jeudi 1 juillet 2010
Statut
Membre
Dernière intervention
15 juillet 2010

Merci ça fonctionne