Excel: nombre positif en nombre négatif

Résolu/Fermé
Medic911 Messages postés 9 Date d'inscription jeudi 1 juillet 2010 Statut Membre Dernière intervention 15 juillet 2010 - 8 juil. 2010 à 04:09
Medic911 Messages postés 9 Date d'inscription jeudi 1 juillet 2010 Statut Membre Dernière intervention 15 juillet 2010 - 9 juil. 2010 à 02:13
Bonjour,

Une colonne contient des nombres et leur somme.


A1 = 100
A2 = 300
A4 = 250
A5 = somme de A1:A4

Comment faire une conition pour que :

Si dans B1 il est ecrit "A" le nombre dans A1 reste positif

Si dans B1 il est écrit "S" le nombre dans A1 devient négatif


La même chose pour les autres lignes.


Merci !

1 réponse

Mytå Messages postés 2969 Date d'inscription mardi 20 janvier 2009 Statut Contributeur Dernière intervention 20 décembre 2016 926
8 juil. 2010 à 04:15
Salut le forum

Au-lieu d'utiliser =Somme("A1:A3")

Utilise =SOMME.SI(B1:B3;"A";A1:A3)-SOMME.SI(B1:B3;"S";A1:A3)
Mytå
1
Medic911 Messages postés 9 Date d'inscription jeudi 1 juillet 2010 Statut Membre Dernière intervention 15 juillet 2010
9 juil. 2010 à 02:13
Merci ça fonctionne
0