Demarrage Apache sous Xampp ( Windows)

Fermé
xam - 5 juil. 2010 à 09:55
 jeffwrh - 30 déc. 2013 à 11:03
Bonjour,

Je rencontre un probleme avec mon serveur apache sous Xampp ...


Il a tres bien fonctionner, car j'ai pu installer OCS et GLPI, mais je n'arrive plus a lancer mon serveur apache, et donc je n'arrive plus à accéder à mes serveurs.

Lors que je vais sur le Xampp control panel application, mysql demarre normalement, mais impossible de relancer mon apache ...


Quelq'un connait le problème ?

Merci d'avance

11 réponses

Le problème c'est que ca a déjà fonctionner et que je n'ai rien installé de plus sur la machine.

Quand je lance le panel de controle, apache se lance, mais s'éteint dans la foulée ...
1
trint Messages postés 531 Date d'inscription lundi 12 janvier 2009 Statut Membre Dernière intervention 21 mai 2012 54
5 juil. 2010 à 10:01
Hello,
Vérifie que tu n'as pas un autre service web qui tourne sur ton pc et donc qui occupe déja le port 80 !
Si c'est le cas modifie ton fichier apache.conf et change le listen:80 avec le port que tu veux, mais un port libre :-)
0
trint Messages postés 531 Date d'inscription lundi 12 janvier 2009 Statut Membre Dernière intervention 21 mai 2012 54
5 juil. 2010 à 10:24
As tu regardé ce que je t'ai dis?
Dans panneau de config/outils d'administration/services as tu un service iis ou autre service web? Toujours dans cette fenètre est ce que tu as un service Apache? Démarré?
0
En regardant les logs d'apache, je me suis apercu que j'avais également un probleme de perl.

hors j'ai DL l'archive avec le perl et copié tous dans le répertoire xampp, mais ca n'a pas fonctionnée ...

Je réinstalle proprement, et je te dis quoi.


Ce qui est étrange, c'est que j'ai fait la meme chose sur un autre ordinateur, et je n'ai aucun probleme :s
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Eh bien voila, je viens de tout réinstaller, et tout fonctionnait jusqu'au moment ou j'ai arreter apache via le panneau de control.

Il m'est désormais impossible de relancer Apache, il se coupe quasiment aussitot que je le relance.


Sinon, je ne pense pas avoir un autre programme qui ecoute sur le port 80, car c'est une machine dédié qui ne servira qu'a ca.
Il y a VNC installé dessus.

Sinon, dans les services, j'ai rien vu de particulier :s
0
trint Messages postés 531 Date d'inscription lundi 12 janvier 2009 Statut Membre Dernière intervention 21 mai 2012 54
5 juil. 2010 à 15:04
VNC n'est pas un problème, si cela ne vient pas d'un soucis de conflit de port d'écoute je ne vois pas pourquoi ton service ne se lancerai pas.
Désolé mais je sèche.
0
C'est surtout que je l'ai fait sur ma machine que je me sert tous les jours, ca fonctionne, et la je veux le faire sur une autre machine qui fera office de serveur, et pas moyens de le faire fonctionner ... a ne plus rien y comprendre ...
0
trint Messages postés 531 Date d'inscription lundi 12 janvier 2009 Statut Membre Dernière intervention 21 mai 2012 54
5 juil. 2010 à 15:14
Ben ca ca pourrai s'expliquer par la présence sur la machine ayant des problèmes, d'un autre service web écoutant sur le port 80 mais bon apparement ce n'est pas le cas.
Si tu as un doute modifie le port d'écoute de ton serveur Apache on sait jamais.
0
j'ai modifier la port dans httpd.conf, en mettant Listen 8080

Mais ca bug toujours :s
0
trint Messages postés 531 Date d'inscription lundi 12 janvier 2009 Statut Membre Dernière intervention 21 mai 2012 54
5 juil. 2010 à 15:41
Erf ben désolé mais je ne vois pas
0
idem je seche complétement ...


merci de l'aide quand meme.
0
LE probleme vient d'OCS ...
0
ton probleme vient de IIS de ton windows stop les services web par defaut sur ton windows ce qui libere le por 80 de ta machine lance port check sur xampp le port 80 doit etre libre
0
j ai aussi un problème quand j ouvre xampp j ouvre mysql et aprée je clic sur apache il salume et il sétin tous de suite apre je fais quoi ?
0
quel version de xamp ? Dans mon cas, c'était la version de xamp qui posait problème.
0
Voila je viens d'installer XAMPP je lance MySql, il marche sa marque running puis je Start Apache il se lance et puis il s'éteint !!! Pourtant je n'ai rien fais d'autres j'ai toucher a rien d'autres !!! Quelqu'un pourrait m'aider svp :(.

Merci d'avace :)
0
C'est la derniere version , j'ai redemarer et tout mes nan toujours pas :(.
0
Il y en effet une histoire de Port, en faite Apache et Skype utilise le même port, ils sont donc en conflit, c'est pourquoi lorsque Skype est ouvert sur votre PC Apache n'arrive pas a se lancer.

Je te propose donc comme solution : Sur Skype va dans "Outils", "Options..", "Avancées" puis "connexion" puis décoche "Utiliser les ports 80 et 443 comme alternative."

Ça a marché pour moi et je n'ai pas eu de problèmes depuis.
0
Merci beaucoup sa a marcher :)
0
Bonjour,
cette réponse est peut être tardive, mais vaut mieux tard que jamais...

Les options décrites si dessus n'ont malheureusement pas fonctionné pour moi.
Voici ma conf :
- XAMMP control panel version 3.2.1 installé sur un DD externe
- Windows Seven

Solution qui fonctionne dans mon cas : démarrer Xammp en mode administrateur.

Si ça peut aider...
0