[EXCEL] Fonction RechercheV [Résolu/Fermé]

Signaler
Messages postés
123
Date d'inscription
dimanche 10 août 2008
Statut
Membre
Dernière intervention
27 janvier 2021
-
Messages postés
123
Date d'inscription
dimanche 10 août 2008
Statut
Membre
Dernière intervention
27 janvier 2021
-
Bonjour,

Je prépare actuellement un petit tableau Excel en vu d'un jeu durant la coupe du monde.

J'ai dans la colonne A la liste 72 joueurs.
Dans la colonne B les points attribués aux joueurs.

en gros :

____A___ ___B__
| casillas | 2 |
------------------------
| lloris | 5 |
-------------------------

J'aimerai créer un tableau de Top&Flop ( les meilleurs et les moins bon joueurs ).


j'ai donc créer un petite tableau sur la meme page:

_________________
| TOP |
------------------------------
| Nomjoueur | Score |
-----------------------------

Pour le score pas de soucis : GRANDE.VALEUR(A1:B72;1)

En revanche j'aimerai qu'il me trouve le nom du joueur correspondant à cette valeur

Je me suis penché sur la fonction RECHERCHEV qui semble répondre à mes attentes :

=RECHERCHEV($H$8;$A$1:$B$72;2) au H8 est la case score


J'obtiens #N/A dans la cellule G8, où j'ai mis ma fonction. Malgré différentes recherche sur internet, impossible de comprendre mon erreur.


Merci d'avance pour vos réponse et excusez moi de ma faible prestation en ASCII Art .



2 réponses

Messages postés
1823
Date d'inscription
vendredi 5 septembre 2008
Statut
Contributeur
Dernière intervention
24 avril 2020
597
Bonjour,

Selon moi il y a deux problèmes :

1/ RECHERCHEV cherche la valeur dans la 1° colonne de la matrice que tu lui donne. Donc pour que cela fonctionne, dans la liste des joueurs et de leur score il faut inverser la colonne score et nom. Ainsi il cherchera bien dans la première colonne le score le plus élévé et donnera le nom dans la 2° colonne (c'est ce que signifie le 2 dans la formule, c'est la colonne du résultat à retourner).

2/ Je te conseille de mettre le paramètre FAUX dans la formule comme ceci :

RECHERCHEV($H$8;$A$1:$B$72;2;FAUX) car sinon il considére que les valeurs sont dans l'ordre croissant (ce qui n'est pas ton cas)

Voilà à essayer

A+
Cordialement,
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
123
Date d'inscription
dimanche 10 août 2008
Statut
Membre
Dernière intervention
27 janvier 2021
38
C'est exactement ca !
Merci beaucoup et bonne journée.

Cordialement


Thibaut