Excel : Tester la présence d'une chaine

Résolu/Fermé
Signaler
Messages postés
9
Date d'inscription
mardi 8 juin 2010
Statut
Membre
Dernière intervention
14 juin 2010
-
Messages postés
17676
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
26 novembre 2021
-
Bonjour,

J'ai déjà posé deux questions mais vu qu'aucune n'a abouti, je vais tenter de faire plus conci :) Retour aux briques élémentaires donc, avec le test de présence d'une chaine de caractères

j'ai une date dans le format

01/06/2002
dans une cellule.

Je veux trouver la chaine de caractère
/06/
dans cette date. Pour cela, j'utilise la fonction


=NB.SI(A1;"*/06/*")


Malheureusement ça ne marche pas et cela me renvoie 0. Si je fais

=NB.SI(A1;"01/06/2002")


Tout fonctionne, cela me renvoie 1.

Est on d'accord sur le fait que les * correspondent à plus ou moins : "quelque soit ce qui se trouve avant à la place de *" ?

J'ai déjà essayé d'utiliser la fonction rechercher, mais pour tout vous dire, la finalité est d'utiliser cette fonction dans une macro, et la fonction remplacer ne fonctionne pas comme je le veux.

J'espère que vous allez pouvoir me fournir quelques pistes !

Merci !

1 réponse

Le problème est que le contenu de la cellule n'est pas du texte !!! En tapant une date, Excel calcule ce jour comme le nième depuis le 1.1.1900, et on a donc un chiffre, avec un format date sur la cellule. Impossible donc d'extraire comme çà.
Par contre, la fonction MOIS() permet de récupérer le 6. Plus qu'à mettre en forme après...
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
9
Date d'inscription
mardi 8 juin 2010
Statut
Membre
Dernière intervention
14 juin 2010

Comment te dire... tu m'as retiré un pieu du pied, je pense que c'est la bonne image. Je vais pouvoir m'en sortir maintenant. Et dire que ça fait près de 2 jours que je me noie dans ce problème.

Mille mercis.
Messages postés
17676
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
26 novembre 2021
4 843
Salut,

je n'avais pas vu que tu avais ouvert plusieurs discussions, regarde ma réponse sur celle ci

https://forums.commentcamarche.net/forum/affich-18084827-utiliser-remplacer-avec-une-macro#newanswer