NB.SI.ENS équivalent Excel 2003 problème

[Résolu/Fermé]
Signaler
Messages postés
2
Date d'inscription
dimanche 6 juin 2010
Statut
Membre
Dernière intervention
6 juin 2010
-
Messages postés
24184
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
-
Bonjour,


Après avoir déjà bien parcouru tous les forums, je me retrouve confronté à un "petit" souci sur Excel 2003.
J'entends croire que l'équivalent de la fonction NB.SI.ENS d'Excel 2007 s'appelle SOMMEPROD sur Excel 2003, malheureusement je n'arrive pas à obtenir le même résultat.
Je possède Excel 07 chez moi mais Excel 2003 au boulot, la formule n'est donc pas compatible.

Voilà, disons que dans la colonne A je note le nom (texte) de différentes machines (ex : machine X, machine Y, machine Z) et dans la colonne B j'inscris la date où ces dites machines tombent en pannes.
J'obtiens donc à la fin une liste (très) longue de pannes.

A B C D
1 machine X 02/05/2010 nombre de pannes de la machine X en mai
2 machine Y 03/05/2010 nombre de pannes de la machine Y en mai
3 machine Z 02/05/2010 nombre de pannes de la machine Z en mai
4 machine Z 06/05/2010
4 machine Z 07/05/2010
5 machine X 16/05/2010
6 machine Y 01/06/2010
7 machine Z 01/06/2010
8 machine X 03/06/2010
9 machine X 04/06/2010

Je voudrais disons en colonne D le nombre de panne par machine sur une période.
Ex : combien de fois la machine X est tombée de fois en pannes durant le mois de mai 2010 ?
En principe grâce à la formule NB.SI.ENS(A1:A9;"machine X";B1:B9;"<01/06/2010"), j'obtiens donc 2, ce qui est bon.

J'y arrive avec NB.SI.ENS mais une fois que je passe à Excel 2003, tout se complique...

Quelqu'un aurait-il une solution ?
C'est assez urgent, je construis des tableaux de bord pour ma boîte...

Merci beaucoup

1 réponse

Messages postés
2491
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
24 septembre 2021
996
Bonjour,
Le problème est lié à l'utilisation d'une date comme critère.
=SOMMEPROD((A2:A20="machine X")*(B2:B20<1/6/2010)) ne fonctionne pas
=SOMMEPROD((A2:A20="machine X")*(B2:B20<40330)) fonctionne (40330 est la valeur du 01/06/2010 en format standard)
=SOMMEPROD((A2:A20="machine X")*(MOIS(B2:B20)=5)) fonctionne
=SOMMEPROD((A2:A20=$F$2)*(B2:B20<$H$2)*(B2:B20>=$G$2)) fonctionne (avec "machine X" en F2 01/05/2010 en G2 01/06/2010 en H2)

Est- ce clair? Si un point reste obscur, revenez.
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci

Messages postés
2
Date d'inscription
dimanche 6 juin 2010
Statut
Membre
Dernière intervention
6 juin 2010

Je vous remercie beaucoup pour cette rapidité et la clarté de l'explication.

J'ai opté pour la dernière solution, ça me permet par ailleurs d'adopter une mise en forme plus esthétique sans changer le reste de données déjà renseignées.

Bonne journée ;)
Messages postés
24184
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 898
Bonjour,

J'ajoute que l'on pourrait aussi faire :
...*(B2:B20<("01/06/2010"*1))
excel convertira la date.

eric