Pb pour l'installation de mon serveur DHCP [Résolu/Fermé]

Signaler
-
 lotfis -
salut,

Une fois avoir installer dhcp-server,j'ai bien configuré mon dhcpd.conf, mais je ne peux pas activer mon serveur dhcp

voici l'erreur que j'ai quand je veux mettre activé au démarrage dans les services: arret de dhcp : [ OK ]
lancement de dhcpd : [ECHEC]

et quand je tappe cette commande :
/etc/init.d/dhcpd start

j'ai la même chose.

J'ai donc été voir dans les journaux des systèmes et j'ai ça comme message:

Sep 9 19:53:08 localhost dhcpd: Démarrage de dhcpd failed
Sep 9 19:53:09 localhost dhcpd: Not searching LDAP since ldap-server, ldap-port and ldap-base-dn were not specified in the config file
Sep 9 19:53:09 localhost dhcpd:
Sep 9 19:53:09 localhost dhcpd: ** You must add a global ddns-update-style statement to /etc/dhcpd.conf.
Sep 9 19:53:09 localhost dhcpd: To get the same behaviour as in 3.0b2pl11 and previous
Sep 9 19:53:09 localhost dhcpd: versions, add a line that says "ddns-update-style ad-hoc;"
Sep 9 19:53:09 localhost dhcpd: Please read the dhcpd.conf manual page for more information. **
Sep 9 19:53:09 localhost dhcpd:
Sep 9 19:53:09 localhost dhcpd: If you did not get this software from ftp.isc.org, please
Sep 9 19:53:09 localhost dhcpd: get the latest from ftp.isc.org and install that before
Sep 9 19:53:09 localhost dhcpd: requesting help.
Sep 9 19:53:09 localhost dhcpd:
Sep 9 19:53:09 localhost dhcpd: If you did get this software from ftp.isc.org and have not
Sep 9 19:53:09 localhost dhcpd: yet read the README, please read it before requesting help.
Sep 9 19:53:09 localhost dhcpd: If you intend to request help from the dhcp-server@isc.org
Sep 9 19:53:09 localhost dhcpd: mailing list, please read the section on the README about
Sep 9 19:53:09 localhost dhcpd: submitting bug reports and requests for help.
Sep 9 19:53:09 localhost dhcpd:
Sep 9 19:53:09 localhost dhcpd: Please do not under any circumstances send requests for
Sep 9 19:53:09 localhost dhcpd: help directly to the authors of this software - please
Sep 9 19:53:09 localhost dhcpd: send them to the appropriate mailing list as described in
Sep 9 19:53:09 localhost dhcpd: the README file.
Sep 9 19:53:09 localhost dhcpd:
Sep 9 19:53:09 localhost dhcpd: exiting.

J'ai donc été voir mon fichier dhcpd.conf et je vois pas d'erreur:
#
ddns-update-style none;
ddns-updates off;

Quelqu'un peut me dire pourquoi j'arrive pas a activer le dhcp ?

Merci

6 réponses

Messages postés
1564
Date d'inscription
mercredi 30 mars 2005
Statut
Contributeur
Dernière intervention
22 juin 2007
488
Ton fichier dhcpd.conf est-il au bon endroit ? Par defaut c'est dans /etc/... mais defois selon la distribution ca peut etre ailleurs (par exemple dans /etc/dhcdp/... ).
Tu n'as pas d'erreurs syntax (avec les ";" les "," etc. c'est vachement sensible a ce genre de trucs) ??

Pour tester il vaut mieux demarrer directement par: "dhcpd"
(ou "/usr/sbin/dhcpd" ou "/sbin/dhcpd"). L'avantage: ca affiche directement les messages d'erreurs et je crois ca prend vraiement le fichier de config dans /etc/.

Apart ca tu devrais faire un copier/coller de ton fichier dhcpd.conf ici.
mon fichier dhcpd.conf est effectivement au bon
endroit, à savoir /etc/

J'ai testé en faisant /usr/sbin/dhcpd et effectivement
j'ai une erreur:

/etc/dhcpd.conf line 8: expecting a parameter or
declaration
option domain-name "MSHOME";

Configuration file errors encountered -- exiting


Je pense savoir pourquoi il me mets ça mais je sais
pas comment le régler, en effet, mon client dhcp est
sur un groupe de travail: MSHOME et je n'ai pas changé
mon groupe de travail à mon serveur dhcp pour le
mettre dans le groupe de travail: MSHOME. (c'est resté par défault)

Voici mon fichier dhcpd.conf:
ddns-update-style none; 
ddns-updates off; 

allow unknown-clients;

log-facility local7

option domain-name   "MSHOME";
option subnet-mask 255.255.255.0;
option broadcast-address 192.168.0.255;
option routers 192.168.0.4;



subnet 192.168.0.0 netmask 255.255.255.0 {
range 192.168.0.5 192.168.0.150;
default-lease-time  86400;
max-lease-time 604800;
}




merci de ton aide
J'ai bien configuré mon serveur dhcp avec ce groupe de travail: MSHOME, grâce a webmin

j'ai également regarder dans le smb.conf et MSHOME a bien été écrit

j'ai redémarré le PC
j'ai refait le test /usr/sbin/dhcpd, et j'ai toujours le même message d'erreur
Messages postés
1564
Date d'inscription
mercredi 30 mars 2005
Statut
Contributeur
Dernière intervention
22 juin 2007
488
Je crois tu dois ajouter un ";" derriere la ligne avec log-facility, c.-a-d. =>
log-facility local7;

et cause de ca la ligne suivante avec le domain fait une erreur. Au moins ca me semble necessaire selon le "man dhcpd.conf".

Apart ca, je pense que le domain que tu peux mettre ici n'a rien a voir avec le work-group de Microsoft ou Samba. A ce niveau de TCP/IP ca n'entre pas encore au jeu. C'est seulement le domain internet (par exemple "free.fr"). Si tu veux tu peux meme enlever cette ligne. De toute facon le MSHOME devrait aussi ``marcher'' (la faute etant le ";" ?) mais ca ne fera rien d'important ou util pour ton reseau.

Si ton pc serveur DHCP est aussi le routeur avec la connexion internet tu devrais aussi ajouter une ligne (derrier le "domain ...") comme:
option domain-name-servers 213.228.0.95, 213.228.0.96;

ou tu mets les DNS de ton FAI (ces adresses sont mon exemple pour Free, tu y mettras ce que tu as dans /etc/resolv.conf du serveur s'il est connecte a internet). Avec ca tous tes clients obtiendront du serveur aussi les DNS de ton FAI de facon automatique et pas seulement le numero IP (tres confortable!).
Le parametre domain que tu mets se trouvera plus tard (sur un client linux) aussi dans le fichier /etc/resolv.conf avec la ligne "search <domaine>". Comme ca un nom internet "toto" sera traite comme "toto.free.fr" si tu as choisi le domaine = free.fr. Ca te permettra de tapper de nom plus court dans un navigateur ou avec une commande ssh, telnet, etc.
Je pense ici le MSHOME n'est pas de tout bon mais comme je l'ai dit ci-dessus ca n'est pas la faute du syntax, je crois.
Je te remercie énormément de m'avoir répondu.
Et grâce à toi ça fonctionne, j'ai mis le ";" qui manquait.

je l'ai sans doute négligé car je comprenais pas trop cette ligne de commande. Je pense toutefois qu'elle sert à envoyer des évènements dans un autre fichier... bref si toi tu sais, je veux bien que tu m'explique.

Euh, sinon, vraiment très cool linux. Ca m'a remotivé tout ça.
nue fois configurer le fichier dhcpd.conf vous devez créer un fichier vide dhcpd.leases dans /var/lib/dhcp/