Excel: Ignorer les valeurs non reconnues [Résolu/Fermé]

Signaler
-
Messages postés
2349
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
10 août 2020
-
Bonjour,

Je travaille sur un fichier manipulé par un grand nombre de personnes dans la boite.
J'essaie d'en extraire des informations. Le problème c'est que tout le monde n'entre pas ses données de la même façon. De temps en temps au milieu d'une colonne de chiffres je vais avoir un "NC", un "-" ou peut-être un "x". Comment faire pour que mes formules ne m'affichent pas systématiquement NA, autrement dit que que les formats autres que les chiffres soient ignorés notamment lors de l'utilisation de sommeprod?
N'hésitez pas à me demander de préciser certains points si je ne suis pas clair.



2 réponses

Messages postés
12184
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
31 juillet 2020
2 467
Salut,
Sans connaitre tes formules, difficile de t'apporter LA solution. Voici un exemple avec la formule "SOMME" :
=SOMME(SI(ESTERREUR(A1:A10);0;A1:A10))
Ok, par exemple pour la formule:

=SOMMEPROD(Z2:Z1200*(AF2:AF1200=Feuil1!K10)*(G2:$G$1200=Feuil1!J10)*(B2:B1200>=Feuil1!K8))
Comment faire pour que ma formule ne s'arrete pas à la moindre cellule non reconnue?
Salut ci-joint une maquette où j'explique ce que je cherche à faire. On voit que dans ma colonne "Nb de pièces produites" des notes comme NC ou- apparaissent. Comment faire pour que ma formule ignore ces cellules?
https://www.cjoint.com/?frpd4lSgWp

tontong quand je remplace * par; le message d'erreur s'efface effectivement mais le résultat de ma formule est systématiquement 0 quelle que soit la somme de mes cellules.
Messages postés
12184
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
31 juillet 2020
2 467
la formule :
=SOMMEPROD(SI(ESTNONTEXTE(D17:D26);(D17:D26);0)*(B17:B26=D11)*(C17:C26=C11)*(A17:A26>=D9))-SOMMEPROD(SI(ESTNONTEXTE(D17:D26);(D17:D26);0)*(B17:B26=D11)*(C17:C26=C11)*(A17:A26>=F9))
fonctionne à condition de la valider comme formule matricielle (Ctrl + Shift + Entrée)
Voir ici ton exemple.
Pile poil ce que je voulais. Je travaille beaucoup sur des ficjiers manipulés par pas mal de personnes et ca va pas mal m aider. Un grand merci à toi!!!!
Messages postés
12184
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
31 juillet 2020
2 467
De rien.
Pour t'aider à mieux comprendre ces formules va jeter un oeil à ce site : http://translate.google.fr/... . La traduction de ce site anglais est affreuse, mais cela pourra t'aider.
A+
Messages postés
2349
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
10 août 2020
862
Le séparateur ; ne doit être appliqué que pour le champ D17:D26.
=SOMMEPROD(D17:D26;(B17:B26=D11)*(C17:C26=C11)*(A17:A26>=D9))-SOMMEPROD(D17:D26;(B17:B26=D11)*(C17:C26=C11)*(A17:A26>=F9))
fonctionne sur fichier transmis à 15:54