EXCEL Si 3 conditions, 3 résultats différents [Résolu/Fermé]

Signaler
Messages postés
66
Date d'inscription
jeudi 6 mai 2010
Statut
Membre
Dernière intervention
9 mai 2017
-
 ghofran -
Bonjour,

Je suis confronté à un problème sur excel.
J'aimerai trouver le moyen de remplir une cellule avec 3 possibilités de réponse ( "OUI" "NON" ou "N.A." ) , en fonction du texte que je vais écrire dans une autre cellule.

Dans mon cas je veux:
OUI si la cellule ne contient pas de texte (par défaut)
NON si elle contient le lettre N
N.A. si elle contient la lettre B


Dit comme ça cela parait bidon, mais je suis depuis une après midi la dessus!
Aidez moi SVP! =)

Merci d'avance!


3 réponses

Messages postés
6118
Date d'inscription
jeudi 9 juillet 2009
Statut
Contributeur
Dernière intervention
20 mars 2017
1 478
Bonjour,

=SI(A1="N";
"NON";
SI(A1="B";"NA";"OUI"))


"Trotti Trotta, Monsieur P, il y a des anges qui veulent un bisou..."
"Même les joujou de Monsieur P ont besoin de joujou"
29
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 61329 internautes nous ont dit merci ce mois-ci

Messages postés
66
Date d'inscription
jeudi 6 mai 2010
Statut
Membre
Dernière intervention
9 mai 2017
60
Merci Neliel et chossette9 , grâce à vous j'ai réussi! c'était bien ça.

c'est fou comme les problèmes se résolvent vite grâce à ce forum! Merci à tous.

.... je vais quand même essayer de comprendre la formule, histoire de ne plus être confronté à ce problème par la suite.

thx!
Messages postés
4237
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 243
Bonjour,

en supposant que la cellule à tester est A1, on écrit en B1 :
=SI(A1="N";"Non";SI(A1="B";"N.A";SI(ESTVIDE(A1);"Oui";"")))


Cordialement.
Messages postés
6118
Date d'inscription
jeudi 9 juillet 2009
Statut
Contributeur
Dernière intervention
20 mars 2017
1 478
Je vais t'aider à la comprendre, il s'agit en fait de 2 SI imbriqué (pour mon cas)

En français, cela donne:

=SI(A1="N";"NON";SI(A1="B";"NA";"OUI"))

SI la cellule A1 contient "N" alors écrire "NON" SINON SI la cellule A1 contient "B" alors écrire "NA" SINON écrire "OUI"
Messages postés
4237
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 243
Oui mais dans ce cas là, tu ne prends pas en compte la demande OUI si la cellule ne contient pas de texte (par défaut) , c'est pourquoi j'ai imbriqué 3 SI :

SI A1 contient "N" alors écrire "Non", SINON si A1 contient "B" écrire "N.A", SINON si A1 est vide écrire "Oui", sinon ne rien écrire.

Cordialement.
Messages postés
6118
Date d'inscription
jeudi 9 juillet 2009
Statut
Contributeur
Dernière intervention
20 mars 2017
1 478
Tu as parfaitement raison... mais tu as fait du zèle! Il n'y avait que 3 possibilités selon son énoncé! ;-)
Messages postés
4237
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 243
Ces 3 possibilités en appelle une quatrième par défaut : Si c'est différent des 3 conditions, alors on ne met rien.

De toutes façons, les deux solutions fonctionnent.
Merci Beaucoup ça maaaaaaarcheeeeeeeee