Somme fausse sur excel

Fermé
-
Messages postés
55449
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 janvier 2022
-
Bonjour, j'ai un problème avec excel que je n'arrive pas à résoudre :
voili, voilà :
La somme d'une colonne de montant (€) est erronée, excel prends en compte les calculs demandés dans chaque cellule et pas la valeur affichée arrondie au centièmes.
Exemple : résultat : 3,5689 affiché 3,57€ + 54,2399 affiché 54, 24€ + 124,6348 affiché 124,63€ + 12,1949 affiché 12,19€ = 194,64€ et le somme devrait être 194, 63€ en fonction des résultats affichés.
en bref il fait la somme des cellules (avec leurs formules à des fois bcp de chiffres après la virgule) ou lieu de faire avec leur montant affiché.
La ce n'est qu'un exemple mais lorsque c'est la somme d'une centaine de cellules cela fait un sacré écart au final.
Merci d'avance.

4 réponses

Messages postés
24294
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
27 janvier 2022
7 040
Bonjour,

Fais ta somme avec:
=SOMME(ARRONDI(A2:A5;2))
formule matricielle à valider par shift+ctrl+entrée, doit s'entourer de { } ensuite

Mais bon, c'est un peu tricher et dans l'absolu c'est excel qui a raison...
Essaie déjà en mettant toutes tes cellules au format monétaire mais pas sûr que ça corrige toutes les anos

eric
Messages postés
2105
Date d'inscription
samedi 28 juin 2008
Statut
Membre
Dernière intervention
26 mars 2020
592
Excel prend en compte les valeurs écrites dans les cellules, non pas les valeurs arrondies ou "affichées". Donc si tu as 4 décimales dans une cellule, peu importe le nombre de décimales que tu affiches, Excel va prendre en compte toutes les décimales. Reste à voir s'il y a un moyen de faire savoir à Excel d'additionner seulement les valeurs arrondies... mais moi, je ne le sais pas!
Messages postés
55449
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 janvier 2022
17 229
Bonjour syfer (et les autres).

Il ne faut pas confondre
3,5689 affiché 3,57€ grâce à l'application d'un format à 2 décimales
et
=ARRONDI(3,5689;2) qui donne comme résultat la valeur 3,57

Dans le premier cas, et GrifOli te l'a indiqué, la valeur affichée est différente de la valeur stockée en mémoire.
Dans le second cas, la valeur initiale 3,5689 est modifiée et devient 3,57.
Les personnes qui travaillent sur la paye et les charges sociales connaissent bien cela !
Messages postés
182
Date d'inscription
jeudi 3 juillet 2008
Statut
Membre
Dernière intervention
16 septembre 2010
10
salut
peut tu nous poster le fichier simplifié qui contient l'erreur pour bien comprendre le problème ?
merci