Insertion données excel 2007 [Résolu/Fermé]

Signaler
-
 fanitalia -
Bonjour,

Je souhaiterais insérer des données de la feuille 1 sur la feuille 2 en partant d'un code. Je m'explique:

j'ai une feuille1 Facture et une feuille2 (base de données) Fournisseurs avec colonnes code civilité nom adresse1 code postal adresse2
Comment puis-je insérer automatiquement l'adresse du client en tapant uniquement son code sur la feuille1 facture sous forme d'adresse postale.
C'est pour une présentation facture et devis.

J'espère avoir été clair et surtout vous remercie de votre petite attention.



2 réponses

Messages postés
4347
Date d'inscription
samedi 15 mars 2008
Statut
Contributeur
Dernière intervention
2 novembre 2013
1 272
Salut,

exemple si tu nommes tes feuilles ainsi
Feuille 1 = Facture
Feuille 2 = Clients

Sur ta feuille Clients tu as les colonnes
code civilité nom adresse1 code postal adresse2
tu sélectionnes ton tableau et tu fais insertion/noms et tu le nomme champs

sur ta feuille facture
à titre d'exemple pour les cellules utilisées
en A1 tu entre ton code
en B1 (civilité) tu mets =RECHERCHEV($A$1;champs;2;FAUX)
en B2 (nom) tu mets =RECHERCHEV($A$1;champs;3;FAUX)
en B3 (adresse1) tu mets =RECHERCHEV($A$1;champs;4;FAUX)
en B4 (code postal) tu mets =RECHERCHEV($A$1;champs;5;FAUX)

Donc en entrant ton code en A1 les informations vont afficher automatiquement
si rien n'est trouvé il va afficher #N/A pour éviter cela et inscrire par exemple "Inconnu"

en B1 (civilité) tu mets =SIERREUR(RECHERCHEV($A$1;champs;2;FAUX);"Inconnu")
en B2 (nom) tu mets =SIERREUR(RECHERCHEV($A$1;champs;3;FAUX);"Inconnu")
en B3 (adresse1) tu mets =SIERREUR(RECHERCHEV($A$1;champs;4;FAUX);"Inconnu")
en B4 (code postal) tu mets =SIERREUR(RECHERCHEV($A$1;champs;5;FAUX);"Inconnu")

Tu as aussi un tutoriel pour la fonction RECHERCHEV

Tout problème a une solution...il faut juste être persévérant.
Bonsoir Ricky,

Je viens de rentrer tes formules ça fonctionne à merveille, je ne connaissais pas trop la fonction RECHERCHEV alors merci pour le tuto et ton explication était on ne peut plus clair.

Merci pour ton aide et bonne soirée.
Messages postés
2950
Date d'inscription
vendredi 1 mai 2009
Statut
Membre
Dernière intervention
19 mars 2016
1 270
Bonjour,

Je te propose ceci même si ce n'est pas très élégant :

Dans ta feuille 2 contenant ta base :

Créer trois colonnes supplémentaires
la première afin de faire apparaître : civilité, nom et prénom
la deuxième : l'adresse : N° rue
la troisième : code postal + commune

Utiliser pour cela la fonction =concaténer (A1;" ";B1;" ";C1)
etc..
faire une recopie vers le bas


Ensuite dans ta première feuille

entrer le code client
Puis pour la première ligne adresse utiliser la fonction
=RECHERCHEV($F$3;Feuil2$A$2:$J$3;8)

$F3$ est l'adresse de la cellule contenant ton code client
$A$2:$i$3 représente ma base (ici deux lignes et 10 colonnes)
8 représente la huitième colonne
Recopier cette formule pour les deux autres lignes du bloc adresse.

En entrant donc la référence client, le bloc d'adresse sera recopié automatiquement sur trois lignes

A+

pépé
Merci pour la réponse