Excel 2007 cellule="" cellule="0"

Résolu/Fermé
Signaler
Messages postés
9
Date d'inscription
mercredi 17 mars 2010
Statut
Membre
Dernière intervention
26 mars 2010
-
Messages postés
9
Date d'inscription
mercredi 17 mars 2010
Statut
Membre
Dernière intervention
26 mars 2010
-
Bonjour,

Mon problème doit etre simple et pourtant je bloque dessus.

Voila j'ai une formule du type:

=SIERREUR(RECHERCHEV($B6;'Réalisé par sections'!$A:$R;8;FAUX);"")

Seulement dans certaines cellules j'ai comme total une case vide ce qui est ce que je voulais et dans d'autres j'ai un 0. Pourtant toutes les cellules ont le mm format. Je ne vois aucune différences entres toutes les cellules et je ne sais pas comment supprimer ce 0.

Merci pour votre aide.

4 réponses

Messages postés
55353
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
15 janvier 2022
17 224
Absolument impossible de te répondre sans examiner le fichier !
0
Messages postés
26386
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 janvier 2022
6 177
Bonjour
pas bien compris la formule que vous écrivez ici, mais je pense que si il y a des 0 et des vides c'est parceque soit:
esterreur affiche "" car il n'y a pas de valeur de B6 dans le tableau
recherchev affiche 0 parcequ'il y a une valeur de B6 qui ne correspond à rien dans la colonne 8 du tableau.
pour supprimer le 0 il faudrait rajourter une condition
sirecherchev(..........)=0;"";SI(ESTERREUR(......)etc...
Vous pouvez par contre supprimer l'affichage des 0 pzr option dans l'afficahge d'excel. Pour connaitre la méthode il faut nous dire quelle est la date de votre excel.
Crdlmnt
0
Messages postés
24261
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
16 janvier 2022
7 026
Bonjour,

C'est parce que B6 est trouvé et que la valeur de la colonne 8 correspondante est soit vide, soit =0. Pour excel vide=0 dans les calculs.
Donc soit tu n'affiches pas les 0 (dans 'options' ou par un format personnalisé), soit tu rajoutes un test sur RECHERCHEV($B6;'Réalisé par sections'!$A:$R;8;FAUX)=0

eric
0
Messages postés
26386
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 janvier 2022
6 177
Salut Eric,et bonne journée à toi là on est d'accord!
je compléte ma réponse précédente pour sheebie car je viens de voir (je me réveille) qu'il s'agit de 2007.
Donc pour éviter l'affichage des 0:
cliquez sur le logo en haut à droite des barres de taches
onglet en bas, choisir option excel
dans la liste à gauche: options avancées
et chercher dans le tableau pour décochez:
"afficher les valeurs 0"
Crdlmnt


Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?
0
Messages postés
24261
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
16 janvier 2022
7 026
Salut vaucluse,

Désolé pour le doublons, je traine trop quand j'écris moi ;-)
Bonne journée à toi aussi
eric
0
Messages postés
9
Date d'inscription
mercredi 17 mars 2010
Statut
Membre
Dernière intervention
26 mars 2010

Merci Vaucluse,

C'était bien la bonne solution.
Bonne journée à vous et merci aussi à eric pr votre aide.
Sheebie
0