Calcul nombre de mois entre deux dates

Résolu/Fermé
Signaler
-
 mimi -
Bonjour,
je souhaite calculer sous excel2007 le nombre de mois écoulés entre la date du jour et une date d'entrée.
Merci d'avance

exple :
Monsieur X entré le 15/03/08 est en suivi depuis tant de mois à ce jour.

5 réponses

Messages postés
17686
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
29 novembre 2021
4 848
Salut tout le monde,

Cissou, il est fortement déconseillé d'ouvrir plusieurs discussions sur le même sujet, et encore plus de ne pas suivre les discussions ouvertes et encore plus de ne pas répondre aux propositions, c'set un manque élémentaire de courtoisie.
Des bénévoles donnent de leurs temps sans compter pour partager leurs savoirs et se comportement n'encourage pas les réponses

https://forums.commentcamarche.net/forum/affich-17052660-calcul-du-nombre-de-mois-entre-deux-dates#1
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
21
Date d'inscription
jeudi 4 mars 2010
Statut
Membre
Dernière intervention
19 mars 2010

Bonjour,
admettons que :

A1 soit la date d'entré et met cette cellule en format date
En B1 tapes =AUJOURDHUI() et met cette cellule en format date
En C1 tapes =A1 et met cette cellule en format standard
En D1 tapes =B1 et met cette cellule en format standard
En E1 tapes =ARRONDI((D1-C1)/30;1) ou =ARRONDI((D1-C1)/30;0) en fonction de la précision dont tu as besoin.

Cordialement
méthode simple mais je n'arrive pas un bon résultat
ex : 01/11/1980 au 01/09/2021 = il y a 490 mois. avec ta méthode j'arrive à 497 mois???
la fonction datedif ne fonctionne pas avec excel 2007

Bonjour !
En A1, tu mets la date d'entrée au format jj/mm/aaaa (par exemple)
En B1, tu mets ta cellule en date du jour : AUJOURDHUI() que tu mets en format:
jour/mois/année
En C1, tu colles la fonction JOUR360 et tu arrondis le résultat avec ou sans décimales

Oups !
J'ai oublié: dans ta cellule C1, tu divises JOUR360 par 12 pour obtenir le nombre de mois.
Désolé pour cet oubli
il faut diviser par 30 pour avoir le nombre de mois
Messages postés
26303
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 novembre 2021
6 127
Bonjour
si votre date est en A1, cette formule devrait correspondre.(tout simplement)

=DATEDIF(A1;AUJOURDHUI();"m")
Crdlmnt
PS en prime:
remplacer m par y pour avoir le nombre d'année, par d pour avoir le nombre de jours
Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?