Excel- concaténation avec format date [Résolu/Fermé]

Signaler
Messages postés
1274
Date d'inscription
vendredi 10 juillet 2009
Statut
Membre
Dernière intervention
28 avril 2020
-
Messages postés
1274
Date d'inscription
vendredi 10 juillet 2009
Statut
Membre
Dernière intervention
28 avril 2020
-
Bonjour,

Je cherche à créer un nom de fichier pour sauvegarder. Le format est: yymmdd_Dossier_N°Client_N°Table

yymmdd est en [A1]
dossier c'est par exemple: Resto
N°Client est en [B1] et vaut 12 par exemple
N°Table est en [C1] et vaut 23 par exemple

Mon problème est que lorsque je cherche à concaténer la date, cette dernière se transforme en un nombre décimale qui ne correspond plus au format de la date.

J'ai essayé avec concatener et l'operateur "&" et toujours le même résultat inconvenable.

Quelqu'un aurait-il une solution SVP ?

Merci

5 réponses

Messages postés
25738
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 janvier 2021
5 701
Bonsoir
pour concatener la date :
=JOUR(Cell)&"/"&MOIS(Cell)&"/"&ANNEE(Cell)
et pour mettre un texte en entête:
=Cell texte &" "&JOUR(Cell)&"/"&MOIS(Cell)&"/"&ANNEE(Cell)
Crdlmnt
6
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

Messages postés
1274
Date d'inscription
vendredi 10 juillet 2009
Statut
Membre
Dernière intervention
28 avril 2020
48
Merci Vaucluse!
J'avais pas vu votre message pourtant le 1er.

Merci à tous ça marche!
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 283
bonjour

En formule la même :
=TEXTE(A1;"aammjj")&"_resto_"&B1&"_"&C1
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 283
bonjour

Ceci devrait te donner ton nom :
fich = Format([A1].Value, "yymmdd") & "_Resto_" & [B1].Value & "_" & [C1].Value

J'ai supposé que tu étais en VBA vu ton format.
Messages postés
1274
Date d'inscription
vendredi 10 juillet 2009
Statut
Membre
Dernière intervention
28 avril 2020
48
Merci,

J'essaie de suite!
Messages postés
1274
Date d'inscription
vendredi 10 juillet 2009
Statut
Membre
Dernière intervention
28 avril 2020
48
J'ai répondu trop vite!

Non, je ne suis pas en VBA tout de suite, car je dois d'abord écrire le nom du fichier dans mon rapport.
J'avais déjà cette formule mais je n'arrive pas à la transcrire dans une feuille.

Merci