Insérer une image en php

[Résolu/Fermé]
Signaler
-
 Justiine -
Bonsoir, j'ai un problème et je pense (enfin j'espère xD) que vous pourrez m'aider. Je fais un site entièrement en php et j'ai besoin d'insérer un image. Quand je vais sur mon site, un petit icon apparaît avec un feuille déchirée à la place de mon image. Voici le code que j'ai mis : <img src=ash1.png">
Si je fais un clic droit sur mon icon de feuille déchirée et que je met "Afficher l'image", ça me met :

Error 403 - Forbidden

L'accès au fichier requiert une autorisation.

Merci d'avance :)

7 réponses

Messages postés
1669
Date d'inscription
vendredi 11 mai 2007
Statut
Contributeur
Dernière intervention
21 mai 2012
181
Bonjour,

en fouillant un peu ton site.. je pense que tu mets tes images dans un répertoire 'image'.. de tel sorte que ton chemin devrais plutot etre : /imagess/ash1.png ( http://www.insanitygraph.com/images/ash1.png )

donc =>

<img src="images/ash1.png" />

;)
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
22963
Date d'inscription
mardi 14 mars 2006
Statut
Contributeur sécurité
Dernière intervention
24 décembre 2016
2 564
Bonjour

<img src=ash1.png"> = <img src="ash1.png" />


A essayer, si ça ne fontionne pas il va falloir plus de détails.
Je viens d'essayer et il me met l'icon de feuille brisée = l'icon de feuille brisée.
Que veux-tu comme autres renseignements ?
Messages postés
22963
Date d'inscription
mardi 14 mars 2006
Statut
Contributeur sécurité
Dernière intervention
24 décembre 2016
2 564
l'icon de feuille brisée = l'icon de feuille brisée
Ca veut dire quoi ça ? :O)

Peux-tu nous donner le lien de la page concernée par le problème ?
Messages postés
22963
Date d'inscription
mardi 14 mars 2006
Statut
Contributeur sécurité
Dernière intervention
24 décembre 2016
2 564
Remplace par <img src="/ash1.png" /> (masi bon ...) et surtout vérifie que ton image ash1.png est bien située dans le dossier "racine" (le tout premier là où tu as ta page d'accueil index.php).
Merci beaucoup de votre aide, j'ai réussi !
J'avais effectivement mis mon image dans le dossier "images" mais je l'ai mise dans le dossier racine et tout fonctionne !