Connexion ssh [Fermé]

Signaler
Messages postés
26
Date d'inscription
lundi 2 mai 2005
Statut
Membre
Dernière intervention
9 septembre 2005
-
Messages postés
26
Date d'inscription
lundi 2 mai 2005
Statut
Membre
Dernière intervention
9 septembre 2005
-
Bonjour
svp je suis entrain de configurer un serveur ssh le serveur est un ultra entreprise 3000 sur lequel est installé debian. Mais après configuration lorsque je veux mze loguer sur un autre poste (pc pIV sous mandrake 10) avec la commande ssh login@nom_du_serveur_ssh on a pas de suite on dirait que le poste plante. Que faire?
Merci

4 réponses

sshd est donc lancé sur le serveur ssh sinon tu aurrais un message d'erreur

tu as du donner les droits sinon tu aurrais eut un message d'erreur.

dans les deux cas c'est des messages tres clairs...

peut etre un probleme de metric sur tcp/ip ? (pour tester suffit de lancer une connexion et d'attendre si elle s'ouvre au bout de X temps (même > à 5minutes parfois)) c'est soit ça soit le MTU (toujours dans TCP/IP) qui est pas bon...

hormis ce cas là je ne sais pas comment t'aider.
Messages postés
26
Date d'inscription
lundi 2 mai 2005
Statut
Membre
Dernière intervention
9 septembre 2005

Merci
pour votre contribution au fait c'est le temps de connexion qui est très élever après 6min on n'a pu se connecté.
Au fait comment pourrais je faire pour accélerer la connexion?
Merci encore
Messages postés
29880
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
11 juin 2021
7 121
1) Arrives-tu a pinger ce serveur (a priori oui vu la où tu en es)
2) Est-ce que le serveur ssh (sshd) est lancé ? "service sshd start" ou truc du genre pour le lancer.
3) Est-ce que le port ssh est ouvert ? Utilise nmap pour scanner ton serveur.
4) Est-ce que le fichier de configuration de sshd est ok (/etc/ssh/sshd_config) ?
Messages postés
26
Date d'inscription
lundi 2 mai 2005
Statut
Membre
Dernière intervention
9 septembre 2005

Merci
j'ai pu me connecté après 6min d'attente
Merci
Messages postés
5577
Date d'inscription
mercredi 15 septembre 2004
Statut
Contributeur
Dernière intervention
11 juin 2021
937
Salut Daconcar,

Je suis perplexe en lisant ton message (c'est le moins qu'on puisse dire).


svp je suis entrain de configurer un serveur ssh le serveur est un ultra entreprise 3000 sur lequel est installé debian.

Ok. On va dire que c'est ta machine 1.


Mais après configuration

Tu as donc configuré ton serveur ssh sur la machine 1 Debian.


lorsque je veux mze loguer sur un autre poste (pc pIV sous mandrake 10)

Je comprends que tu veux te loguer sur une machine Mandrake (Machine 2) à partir de ta machine 1 Debian.

Dans ces condition, il n'est pas utile de configurer un serveur ssh sur la machine 1 Debian (il te suffit d'avoir le client ssh). En revanche, tu dois avoir un serveur ssh fonctionnel sur la machine 2 Mandrake (sshd).


avec la commande ssh login@nom_du_serveur_ssh on a pas de suite on dirait que le poste plante. Que faire?

Tu dois finir par avoir un message d'erreur. Poste nous ton message d'erreur.

Fait aussi les tests suivants et postes ici les résultats si le coeur t'en dis :

- fait un ping de la machine 2 à partir de 1,
- vérifie que sshd est lancé sur la machine 2 (ps aux | grep sshd),
- fait un ssh login@127.0.0.1 pour tester ton serveur ssh en local sur la machine 2,
- sur la machine 2 vérifie que ton firewall ne bloque pas le port 22 entrant,
- sur la machine 1 fait un "telnet ip.serveur.2.mandrake 22" avec l'adresse IP de la machine 2.

Sinon, à tout hasard, la temporisation importante que tu sembles constater ne serait-elle pas due à un problème de résolution de noms ?

De la machine 1, un ssh login@ip.serveur.2.mandrake change-t-il quelque chose ?


Dal
Messages postés
5577
Date d'inscription
mercredi 15 septembre 2004
Statut
Contributeur
Dernière intervention
11 juin 2021
937
Bien sûr, si en réalité tu essayais de te loguer de la machine 2 vers la machine 1, tu inverses les numéros dans la liste de tests ci-dessus :)


Dal
Messages postés
26
Date d'inscription
lundi 2 mai 2005
Statut
Membre
Dernière intervention
9 septembre 2005
>
Messages postés
5577
Date d'inscription
mercredi 15 septembre 2004
Statut
Contributeur
Dernière intervention
11 juin 2021

Comment faire pour accélerer la connexion.
Merci
Messages postés
26
Date d'inscription
lundi 2 mai 2005
Statut
Membre
Dernière intervention
9 septembre 2005

Merci
au fait je me suis loguer sur le poste Debian a partir du poste mandrake.
J'ai réussi après 6min d'attente.
Merci