Serveur FTP (proftpd) avec No-Ip

Résolu/Fermé
__fabrice - 11 mai 2005 à 15:36
 adnbenji - 19 mars 2010 à 06:56
salut à tous,

Je viens de finir d'installer no-ip pour avoir un dns dynamique et j'aimerai installer et configurer un serveur FTP pour que mes amis puisse venir recuperer des fichier directement sur mon pc. (Mandrake 10.1 et Routeur SMC)

Bon, j'ai essayé avec Proftpd, çà marche bien en local (en ligne de commande et par un lecteur FTP).
Mon DNS (no-ip) marche aussi depuis l'exterieur, des amis ont testé.
Par contre, ils n'arrivent à se connecter à mon FTP.

Merci de vos conseils,
Fabrice

10 réponses

kilian
Messages postés
8731
Date d'inscription
vendredi 19 septembre 2003
Statut
Modérateur
Dernière intervention
20 août 2016
1 521
12 mai 2005 à 20:02
Compare ton adresse no-ip et ton adresse ip publique, tu es sûr que ce sont les mêmes?
Et tu as essayé de te connecter avec ton ip publique directement?
1
>> Compare ton adresse no-ip et ton adresse ip publique, tu es sûr que ce
>> sont les mêmes?
Heuuu, j'avoue ne pas etre un pro :(. J'ai bien mon adresse no-ip, mais comment savoir mon adresse ip publique ? (par ifconfig : 192.168.1.13 ?)

>>Et tu as essayé de te connecter avec ton ip publique directement?
Comment je fais ?...

Comment je le disais, la connection par le web avec mon adresse no-ip marche tres bien.

Merci
Fabrice
0
kilian
Messages postés
8731
Date d'inscription
vendredi 19 septembre 2003
Statut
Modérateur
Dernière intervention
20 août 2016
1 521
12 mai 2005 à 21:40
Par le web avec ton adresse no-ip ça marche?

Tu as bien tapé ftp://login@ton_adresse_no-ip.org (ou .com bref....)

Si ton ftp est ouvert aux clients anonymes, c'est anonymous@ton_adresse etc...
Attention, il ne faut pas d'http:// devant, il faut ftp://
Je dis ça juste au cas ou...

Pour savoir ton ip publique (j'entend par là celle fournie par ton fournisseur d'accés, ton ip sur internet, pas celle de ton réseau local), va sur ce site:
http://www.whatismyip.com/

Si tu n'as pas de firewall, fais un ping sur ton adresse no-ip (dans un shell, tapes ping ton-adresse-no-ip.org) puis compare l'adresse ip que va te donner ce ping avec ton ip. Puis vois si c'est la même pour être sur que ton adresse no-ip marche....
0
kilian
Messages postés
8731
Date d'inscription
vendredi 19 septembre 2003
Statut
Modérateur
Dernière intervention
20 août 2016
1 521
12 mai 2005 à 21:43
Si le problème ne vient pas de ton adresse no-ip, quelques pistes:
_ Tu as configuré ton serveur pour qu'il n'accepte que certaines connexions....

Là il faudrait voir ton fichier proftpd.conf (dans /etc sûrement)...
Ou alors tu as un firewall qui bloque l'accés...
0
kilian
Messages postés
8731
Date d'inscription
vendredi 19 septembre 2003
Statut
Modérateur
Dernière intervention
20 août 2016
1 521
12 mai 2005 à 21:44
Mais j'y pense, tu es derrière un routeur?
Ta machine n'est pas connectée directement sur internet, elle passe par un routeur?

Si c'est le cas le problème vient de là....
0
angelike
Messages postés
149
Date d'inscription
mercredi 28 avril 2004
Statut
Membre
Dernière intervention
17 janvier 2007
11
11 mai 2005 à 15:51
0
merci, mais cela ne m'aide pas.

J'ai fais ceci :

- avec la ligne de commande ftp cela met : hôte inconnu ... ... ...
- avec un navigateur : "le serveur n'autorise pas les connexions anonymes ou l'adresse de messagerie n'a pas été accepté" avec la boite de saisie du nom de l'utilsateur et du mot de passe.
Si on rentre ces infos : impossible de se connecter au serveur ftp ... ...

En faisait un tail -f /var/log/proftpd/proftpd.log, lors d'un test avec un navigateur, il y as des soucis d'authentification. Mais pourquoi en local, çà marche alors ?
Par le FTP en ligne de commande, j'ai le message qui est cité plus haut, mais aucune trace dans le log.

Fabrice
0
Utilisateur anonyme
12 mai 2005 à 21:54
-1- mon adresse no-ip est bien la meme que mon adresse ip publique

-2- je suis derriere un routeur, mais j'ai fait une redirection du port 21 (tcp et udp) vers mon adresse reseau (192.168.1.13)

-3- j'ai un firewall, mais je n'ai pas bloqué le port 21

-4- je ping correctement l'ip de no-ip

-5- je n'accepte pas les connexions "anonymous" (proftpd.conf) mais je fais "ftp://anonyme_ftp@mon_site_ftp.myftp.org" (qui marche uniquement en local).
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
kilian
Messages postés
8731
Date d'inscription
vendredi 19 septembre 2003
Statut
Modérateur
Dernière intervention
20 août 2016
1 521
12 mai 2005 à 21:58
Et depuis le navigateur chez toi ça marche bien? (avec l'adresse no-ip)...
0
Utilisateur anonyme
12 mai 2005 à 22:04
oui, çà marche impec :)
0
kilian
Messages postés
8731
Date d'inscription
vendredi 19 septembre 2003
Statut
Modérateur
Dernière intervention
20 août 2016
1 521
12 mai 2005 à 22:07
Bon alors le problème ne vient ni de l'adresse, ni du routeur je pense.
Tu n'aurais pas une directive dans proftpd.conf (chercher dans /etc ou /etc/proftpd) qui pose des restrictions sur certaines adresses?
0
Utilisateur anonyme > kilian
Messages postés
8731
Date d'inscription
vendredi 19 septembre 2003
Statut
Modérateur
Dernière intervention
20 août 2016

12 mai 2005 à 22:26
non, je n'ai rien de bien extraordinaire dans le proftpd.conf. Veux tu le voir ?, par mail ?

Merci
Fabrice
0
kilian
Messages postés
8731
Date d'inscription
vendredi 19 septembre 2003
Statut
Modérateur
Dernière intervention
20 août 2016
1 521 > kilian
Messages postés
8731
Date d'inscription
vendredi 19 septembre 2003
Statut
Modérateur
Dernière intervention
20 août 2016

12 mai 2005 à 22:34
Je dis pas non mais je pars demain et je reviens pas avant deux jours :-)
Donc c'est comme tu veux :-)

En attendant on peux chercher ailleurs:

Tu as quoi comme message d'erreur dans tes logs? Et ceux qui se connectent depuis l'exterieur, ils ont quoi comme soucis? Une erreur? Un refus de connexion? Un hôte non-trouvé?
0
Utilisateur anonyme > kilian
Messages postés
8731
Date d'inscription
vendredi 19 septembre 2003
Statut
Modérateur
Dernière intervention
20 août 2016

12 mai 2005 à 23:01
-- Dans mes logs : --

May 12 19:44:07 mon_serveur_ftp proftpd[19392] mon_serveur_ftp (d80-170-8-139.cust.tele2.fr[80.170.8.139]): FTP session opened.

May 12 19:44:10 mon_serveur_ftp proftpd[19392] mon_serveur_ftp (d80-170-8-139.cust.tele2.fr[80.170.8.139]): PAM(anonyme_ftp): Authentication failure.

May 12 19:44:10 mon_serveur_ftp proftpd[19392] mon_serveur_ftp (d80-170-8-139.cust.tele2.fr[80.170.8.139]): USER anonyme_ftp (Login failed): Incorrect password.

May 12 19:44:10 mon_serveur_ftp proftpd[19392] mon_serveur_ftp (d80-170-8-139.cust.tele2.fr[80.170.8.139]): FTP session closed.

La personne qui a testé avec moi n'a, je crois, rien tapé du tout apres avoir saisie l'adresse ftp (sous IE), et il y a çà : " le serveur n'autorise pas les connexions anonymes ou ou l'adresse de messagerie n'a pas été accepté".

Au fait, et si le serveur ftp voulait uniquement une connexion "anonymous", mais, comme je l'ai dis, j'ai supprimer cette option par mesure de sécurité.

Fabrice
0
kmf31
Messages postés
1564
Date d'inscription
mercredi 30 mars 2005
Statut
Contributeur
Dernière intervention
22 juin 2007
496
12 mai 2005 à 22:39
Essaie d'ajouter dans le fichier: /etc/hosts.allow
la ligne:
in.ftpd:ALL

ou si ca ne marche pas:
proftpd:ALL

(mais je crois la 1ere ligne doit etre bon). Apres il faut eventuellement redemarrer proftpd et/ou xinetd. Le fichier /etc/hosts.allow fait une espece de filtrage en plus du pare feu (comme une 2nde couche independante) pour les services comme ftp, telnet, http et eventuellement ssh.
Regarde aussi ici:
http://www.linuxquestions.org/questions/showthread.php?threadid=184344

Si proftpd est gere par xinetd regarde aussi si dans le repertoire:
/etc/xinetd.d/
il n'y a pas un fichier appele "proftpd" et si la dedans il n'y a pas de ligne "disable=yes", si oui passer a: "disable=no" et redemarrer "xinetd" apres.
0
Utilisateur anonyme
12 mai 2005 à 23:11
bon, je vais essayer, mais proftpd est lancé par inet et non par xinetd.

Fabrice
0
Utilisateur anonyme
12 mai 2005 à 23:32
bonne nouvelle, çà marche :), on dirai que c'est l'option de kmf31, j'ai rajouté "in.ftpd:ALL" dans le "/etc/hosts.allow"

C'est super cool, merci infiniment à tous :)

Fabrice
0
glopglop82
Messages postés
1
Date d'inscription
jeudi 1 mai 2008
Statut
Membre
Dernière intervention
1 mai 2008

1 mai 2008 à 08:44
Bonjour à toutes et tous ,
je comprends bien que je suis sur un forum plutôt linux , mais mon problème est exactement le même que celui de fabrice mis à part que je suis sous xp sp2 et que mon ftp tourne via typsoft http://www.typsoft.com . Quand je dis même problème , c'est pour ainsi dire à la virgule prés , jusqu'au faï :)
Donc j'aimerais savoir si la soluce apportée par kmf31 s'applique aussi à mon O.S .
"Essaie d'ajouter dans le fichier: /etc/hosts.allow
la ligne:

in.ftpd:ALL"

merci de vos réponses.
0
Bonjour GlopGlop82...
Attention tu postes dans une question de 2005 !!! Je pense pas que tu auras une réponse des différents intervenants. Désolé, moi je ne peux t'aider aussi le mieux est de recréer un nouveau post

Bonne journée,
Flupke
0
je veux savoir comment faire un serveur ftp,pour partager des adresses avec mes amies.
merci d'avance
0
salut j'aimerai savoir comment le logiciel no ip mache parceque je l'ai installé mais mon IP ( qui est dynamique ) ne le sauvegarde pas lors de la deuxieme connection;
0