Calc Open Office> Figer une plage de calcul [Résolu/Fermé]

Signaler
-
Messages postés
53111
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 janvier 2021
-
Bonjour à tous,

mon problème à l'air simple mais je tourne en rond dessus sans parvenir à trouver une solution ni dans l'aide openoffice ni dans le forum.

Ce que j'aimerai c'est "figer" la référence d'une plage de cellules (en l'occurrence pour faire une somme) de manière "définitive", de "l'ancrer" sur une référence . C'est un peu différent de rendre absolu les références aux cellules utilisées. Je m'explique par l'exemple :

J'ai la somme suivante : SOMME (B1:C1). Je souhaite que ma somme soit toujours faite sur cette plage B1:C1.

Ors si j'ajoute une colonne avant ma plage (en A ou B), ma plage se décale en C1:D1.

Le fait de rendre les références aux colonnes absolues (avec SOMME ($B1:$C1) ne résout pas le problème. La plage se déplace invariablement en $C1:$D1 puis en $D1:$E1 etc...

Dans le cas d'une plage "non finie" qui augmente au fur des ajouts de colonnes, l'astuce que j'ai trouvé est de faire commencer la plage dans une colonne vide et d'ajouter les colonnes à partir de celle vide. Ainsi, je n'ai pas à redéfinir à chaque ajout le début de ma plage. Mais dans le cas d'une plage "finie", je sèche...

Pour résumer, on pourrait aussi traduire ma demande par : "faire une opération" sur les "x premières lignes/colonnes".

Merci d'avance pour votre aide !

3 réponses

Messages postés
3766
Date d'inscription
jeudi 20 mars 2008
Statut
Membre
Dernière intervention
13 janvier 2021
939
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

Merci pur cette réponse mais le sujet traité sur le forum ne correspond à ma demande.

Il traite de la notion de référence "absolu" et "relative" dans les valeurs d'une cellule.

Mon problème correspond à la définie de manière"absolue" d'une plage de valeur "ex: que les valeurs à prendre en compte soient TOUJOURS les valeurs des cellules entre la colonne X et la colonne Y même si en ajoutant des colonnes (X devant X+1 et Y devant Y+1)". Ce pb ne se résoud pas avec une définition absolue des "coordonnées" d'une celulle (via le signe "$").

Donc, un petit "up" pour ma question toujours d'actualité :)
Messages postés
3766
Date d'inscription
jeudi 20 mars 2008
Statut
Membre
Dernière intervention
13 janvier 2021
939
Et moi je pense que si.
Il suffit de rendre absolue la référence de la colonne et de la ligne.
SOMME ($B$1:$C$1)

Encore merci OOoForum et toutes mes excuses pour le message d'hier. Je viens de le relire... mouais... :)

J'ai bien entendu fait l'essai avant de publier ma question en testant toutes les combinaisons "d'absolutisation" des références des cellules (notamment avec le sympathique raccourci "Maj+F4" ;)

Mais cela ne change rien. Dans l'exemple utilisé, la plage "$B$1:$C$1" se décale d'une colonne (ou ligne) si j'insère une colonne (ou ligne) avant la colonne "B" ou la ligne "1" (la plage devient "$C$1:$D$1" pour une colonne insérée ou "$B$2:$C$2" pour une ligne insérée etc...)

Ce que je souhaite, toujours en gardant l'exemple B1:C1, c'est ajouter à ma plage des valeurs à partir de la colonne "B" ("insérer des colonnes") tout en gardant "fixe" la taille de ma plage (dans l'exemple sur 2 colonnes). Et que donc ma plage soit toujours définie en "$B1:$C1"

La seule solution que j'ai trouvé et qui est un poil fastidieuse est à chaque insertion de colonne/ligne de redéfinir dans la formule la plage (en "glisser-déposer"). Argh :)
Bonjour,
Le sujet est vieux... mais visiblement sans solution.
Que diriez vous de :
=SOMME(INDIRECT("$B$1"):INDIRECT("$C$1")) ?
Cordialement,
F
Messages postés
53111
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 janvier 2021
15 082
Moi, je dirais que ça fonctionne !
Très astucieux et simple à la fois ...
Messages postés
23807
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
18 janvier 2021
6 573
voire même :
=SOMME(INDIRECT("$B$1:$C$1"))

eric
Messages postés
53111
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 janvier 2021
15 082
... encore plus astucieux et plus simple !