Wifi sous Debian

Fermé
limbergh Messages postés 658 Date d'inscription dimanche 8 juillet 2007 Statut Membre Dernière intervention 29 juin 2010 - 13 août 2009 à 10:50
 Maxence - 13 août 2009 à 21:44
Bonjour à toutes et à tous,

j'ai un problème de configuration wifi...

lspci | grep Network

07:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)


j'ai installlé le paquet wireless-tools

ensuite j'ai éditer le fichier /etc/network.interfaces


# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback
auto eth0
iface eth0 inet static
address 192.168.xxx.xxx
netmask 255.255.0.0
broadcast 192.168.255.255
gateway 192.168.xxx.xxx
network 192.168.0.0

auto wlan0
iface wlan0 inet static
address 192.168.xxx.xxx
netmask 255.255.0.0
broadcast 192.168.255.255
gateway 192.168.xxx.xxx
network 192.168.0.0
wireless-essid dereferefe
wireless-key xxxxxxxxxx



ensuite j'ai fais un ifup wlan0

et il marque
ifup: interface wlan0 already configured


la commande route donne ceci ===>

Table de routage IP du noyau
Destination     Passerelle      Genmask         Indic Metric Ref    Use Iface
192.168.0.0     *                     255.255.0.0     U     0      0        0 eth0
192.168.0.0     *                     255.255.0.0     U     0      0        0 wlan0
default         192.168.xxx.xxx   0.0.0.0         UG    0      0        0 wlan0
default         192.168.xxx.xxx   0.0.0.0         UG    0      0        0 eth0


Donc pour moi il doit être correctement configuré mais j'arrive pas à me connecter...
Merci d'avance pour vos interventions...
A voir également:

1 réponse

quel est la configuration ip du routeur ?