Valeur erreur sur excel

Fermé
Signaler
-
Messages postés
26318
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 décembre 2021
-
Bonjour,
J'ai 3 cellules soit Qté_vendue, Prix_vendu et Total
Pdt A + Pdt B =Total
Cette formule ne peut pas fonctionner si par exemple pdt 2 est une valeur erreur alors il affiche des #Valeur dans la cellule Total.
Pourquoi? et surtout que faire...
NB j utilise la fonction recherchev pour avoir les pdt A et B donc si la valeur de B est nul je dois avoir le total de A normalement !!!
Merci

3 réponses

Messages postés
4804
Date d'inscription
dimanche 22 juillet 2007
Statut
Contributeur
Dernière intervention
7 octobre 2021
4 350
Bonjour,

On ne sait pas où cherche Recherchev.
A mon avis, il faudrait que tu joignes un petit bout de fichier avec https://www.cjoint.com/ et coller ensuite le lien ici
[IMG]http://www.tsawri.com/out.php/i30394_Sanstitre.jpg[/IMG]

C2=A2+B2

donc meme si B2 est une valeur erreur je veux avoir le total en considerant que b2 est egale a 0
et pareil pour A2
Messages postés
26318
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 décembre 2021
6 136
Bonsoir
le mieux serait effectivement d'en savoir plus pour vous aider à éliminer les affichages d'erreur dans vos recherches.
Toutefois si vous n'y parvenez pas, vous pouvez toujours essayez:
=SI(ET(ESTERREUR(A1);ESTERREUR(B1));0;SI(ESTERREUR(B1);A1;SI(ESTERREUR(A1);B1;A1+B1)))
crdlmnt