Somme cellule texte identiques [Résolu/Fermé]

Signaler
Messages postés
28
Date d'inscription
mardi 21 juillet 2009
Statut
Membre
Dernière intervention
13 avril 2015
-
Messages postés
28
Date d'inscription
mardi 21 juillet 2009
Statut
Membre
Dernière intervention
13 avril 2015
-
Bonjour,

Je voudrais additionner les cellules de la colone B correspondant à une valeur de la colonne A dont le texte est identique sans avoir à noter dans la formule tous les noms, et que le résultat soit en colonne C.

Nom montant Résultat
Cécile 10
Cécile 50
Aurélie 60
Jean 90
Jean 50
Jean 40

Je voudrais que toutes les montants de Jean s'additionnent dans résultat sans rentrer le prénom Jean dans la formule et qu'excel reconnaisse le texte tout seul.

J'ai bien essayé avec somme.si mais il faut préciser le texte.

Merci d'avance....

5 réponses

Messages postés
128
Date d'inscription
lundi 8 juin 2009
Statut
Membre
Dernière intervention
4 janvier 2012
9
tu peux poster ton fichier je comprends pas ton enigme ^^
Messages postés
28
Date d'inscription
mardi 21 juillet 2009
Statut
Membre
Dernière intervention
13 avril 2015

Bonjour,

Le fichier n'est pas bâti justement en fait je veux résoudre ça :
Colonne A représente une liste de nom
Colonne B des montants qui leurs ont été versés
Collone C total des montants versés à chaque nom

Je voudrais Si texte A1 = texte A3 alors somme de B1+B3 dans C3 mais sans préciser le texte de A dans la formule.

J'espère être plus claire.

Merci de ta réponse
Messages postés
17289
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
22 octobre 2020
4 301
Salut,

Avec SOMMEPROD qui fait référence à une cellule, dans mon exemple la cellule D1 qui contient soit une liste de validation contenant les Noms ou une saisie directe du nom

=SOMMEPROD(B1:B25*(A1:A25=D1))

Si tu rencontres un problème je te posterai un exemple

A+
Mike-31

Un problème sans solution est un problème mal posé  (Einstein)
Messages postés
28
Date d'inscription
mardi 21 juillet 2009
Statut
Membre
Dernière intervention
13 avril 2015

Bonjour,

justement je voudrais ne pas avoir à saisir tous les noms... car ils sont nombreux et variables

Merci de ta réponse
Messages postés
17289
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
22 octobre 2020
4 301
Salut,

Avec le lien ci-dessous, récupères un fichier avec plusieurs possibilités de formules

=SOMMEPROD($B$2:$B$25*($A$2:$A$25=$A2))

=SI(A2<>"";SI(EQUIV(A:A;A:A;0)=LIGNE(); SOMMEPROD($B$2:$B$25*($A$2:$A$25=$A2)); "déjà comptabilisé");"")


https://www.cjoint.com/?idldUORnOU

A+
Mike-31

Un problème sans solution est un problème mal posé  (Einstein)
Messages postés
28
Date d'inscription
mardi 21 juillet 2009
Statut
Membre
Dernière intervention
13 avril 2015

MERCI MERCI MERCI c'est trop trop trop trop CCOOOLLL
C'est exactement ce qu'il fallait!!!!!!!!