Moyenne par mois avec Excel

[Fermé]
Signaler
Messages postés
18
Date d'inscription
samedi 24 janvier 2009
Statut
Membre
Dernière intervention
8 janvier 2013
-
Messages postés
17239
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
24 septembre 2021
-
Bonjour,

J'ai un tableau a 2 collones

La premiere contient des dates (sur 3 ans)
sous le format JJ/mm/AAAA,

La seconde un prix

Sachant que pour chaque jour il peut avoir plusieurs prix

Je souhaite avoir au final un tableau comme celui ci

Janvier 2006 moyenne prix
Fevrier 2006 moyenne prix
.....

Y a t'il une formule permettant de rendre cela plsu rapide, ou une fonction du TCD qui permetrait de le faire...


Merci a vous

5 réponses

Messages postés
17239
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
24 septembre 2021
10 590
Bonjour,

Oui, c'est tout à fait à faire en TCD.

Tu crées le TCD avec le champ Date en colonne et le champ Montant pour les données. Par défaut le champ Montant sera en somme, tu iras dans les propriétés de ce champ pour choisir Moyenne.

Ensuite, un clic droit sur le champ Date => Grouper et afficher le détail => Grouper
et tu choisis par mois.

m@rina
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci

Messages postés
18
Date d'inscription
samedi 24 janvier 2009
Statut
Membre
Dernière intervention
8 janvier 2013

Ca marche nickel

Merciiiiiii
Messages postés
822
Date d'inscription
mercredi 15 octobre 2008
Statut
Membre
Dernière intervention
8 octobre 2011
181
bonjour;
on supose que les date sont dans la colonne A et les prix sont dans la colonne B
pour le mois de février et l'année 2006:
=SOMMEPROD((ANNEE(E1:E14)=2006)*(MOIS(E1:E14)=2)*(F1:F14)/SOMMEPROD((ANNEE(E1:E14)=2006)*(MOIS(E1:E14)=2)*1))
Messages postés
18
Date d'inscription
samedi 24 janvier 2009
Statut
Membre
Dernière intervention
8 janvier 2013

petit probleme... je suis alle trop vite dans ma joi

Qd je fais trier il compulse tous les mois de janvier ensemble au lieu d'avoir une moyenne pour chaque janvier (ou fevrier...) de chaque année, j'ai la moyenne des janviers de 2007 2008 et 2009 sur une seule ligne...

Une idée
Messages postés
17239
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
24 septembre 2021
10 590
Re...

Dans le menu Grouper, il faut simplement que tu coches Mois ET Année.

m@rina
Messages postés
822
Date d'inscription
mercredi 15 octobre 2008
Statut
Membre
Dernière intervention
8 octobre 2011
181
=SI(MOIS(A1)=01;A1;" ") et pius faite dupliquez cette fonction