Excel compter des valeurs [Résolu/Fermé]

Signaler
Messages postés
55
Date d'inscription
jeudi 16 juillet 2009
Statut
Membre
Dernière intervention
18 février 2011
-
Messages postés
55
Date d'inscription
jeudi 16 juillet 2009
Statut
Membre
Dernière intervention
18 février 2011
-
Bonjour,

Je travaille sur un tableur Excel et je cherche à compter le nombre de valeur d'une colonne qui selon une autre colonne sont différentes de 0.

Ex: colonne A j'ai 5 noms différents
colonne B j'ai 5 valeurs = ou > 0

Comment savoir combien de noms ont une valeurs différentes de zéro?
Et est-il possible par une formule de lister ces noms?

Merci de trouver une solution à ce problème avec une formule Excel si possible sans utiliser le VBA!

A tous ceux qui peuvent répondre

7 réponses

Messages postés
2950
Date d'inscription
vendredi 1 mai 2009
Statut
Membre
Dernière intervention
19 mars 2016
1 264
Bonjour,

Pour afficher le nombre de personnes dont la valeur est égale à 0 :
(la colonne B contient tes différentes valeurs)

=NB.SI(B2:B6;0)
Pour afficher le nombre de personnes dont la valeur est >0

=NB(B2:B6)-NB.SI(B2:B6;0)

Pour afficher ces personnes, utiliser un filtre élaboré en prenant comme critère >0 avec copie dans une autre feuille ou un autre emplacement.

A+

pépé
10
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57505 internautes nous ont dit merci ce mois-ci

Messages postés
12182
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
23 juillet 2020
2 457
Salut,
La formule est certainement la suivante :
Si tes noms sont dans la plage A1:A5 et tes chiffres dans la plage B1:B5 tu inscris par exemple en A6 :
=NB.SI(B1:B5;"<>0")

Messages postés
822
Date d'inscription
mercredi 15 octobre 2008
Statut
Membre
Dernière intervention
8 octobre 2011
162
bonjour;
voici la formule :
=SI(B1<>0;A1;" ")
Messages postés
55
Date d'inscription
jeudi 16 juillet 2009
Statut
Membre
Dernière intervention
18 février 2011
3
Merci tout le monde
et pour ce qui était de ma Seconde requête cad de lister les noms ayant une valeurs différentes de zéro.

le problème c'est que je ne peux pas faire de filtre sur le tableau source car je dois le laisser intact donc je pensais à une formule qui puisse me les extraires. ou si il est possible de les grouper dans une liste déroulantes

pour reprendre l'exemple de "pépé", une liste avec: Pierre
Jules
JP

enfin il faut que chaque nom soit visible pour que cela ressorte sur un tableau de bord.

Merci de votre aide
Messages postés
2
Date d'inscription
jeudi 16 juillet 2009
Statut
Membre
Dernière intervention
16 juillet 2009

Bonjour

si j'ai bien compris...

a) Pour compter le nombre de noms qui ont une valeur non nulle :

=nbval(tu sélectionnes toutes tes valeurs>ou=0)-nb.vide(tu sélectionnes toutes tes valeurs>ou=0)


b) fais un filtre automatique pour ne lister que les noms avec une valeur non nulle
Sélectionner dans ton tableau la 1èligne constituée de noms de rubriques
Données/Filtrer/Filtre automatique

Puis tu déroules la rubrique de tes valeurs et tu choisis non vide ou alors Filtre personnalisé puis différent de 0

Voilà
Messages postés
2950
Date d'inscription
vendredi 1 mai 2009
Statut
Membre
Dernière intervention
19 mars 2016
1 264
Compléments :

Noms Code
Pierre 10
Paul 0
Jules 5
Emile 0
jp 50

Code
>0

Nb personnes =NB(B2:B6)
=0 =NB.SI(B2:B6;0)
>0 =NB(B2:B6)-NB.SI(B2:B6;0)

Noms Code
Pierre 10
Jules 5
jp 50
Messages postés
55
Date d'inscription
jeudi 16 juillet 2009
Statut
Membre
Dernière intervention
18 février 2011
3
Merci Smartway c'est ce qu'il me manquais!