Formule sous excel 2007 [Résolu/Fermé]

Signaler
-
 tiflo46 -
Bonjour,
j'aimerais avoir de l'aide:
je travail sous excel 2007, je souhaite faire une formule de manière a ce que:
lorsque dans une cellule la valeur est >=25 le mot important s'écrive et
lorsque dans cette meme cellule la valeur est >=50 le mot prioritaire s'écrive.

je voudrais que ces 2 paramètres rentrent dans la mm formule. Merci d'avance pour votre aide cordialement.

7 réponses

Messages postés
14200
Date d'inscription
mercredi 24 décembre 2008
Statut
Contributeur
Dernière intervention
6 août 2013
3 695
=SI(C3>=50;"Prioritaire";SI(C3>25;"Important";SI(C3=25;"Important";"")))

C3 à remplacer par ta case.

Si C3 est supérieur ou égale à 50, alors on écrit Prioritaire, sinon, on vérifie si C3 est supérieur à 25, si oui on marque Important, sinon, on vérifie si C3 est égal à 25, si oui on marque Important, sinon vide.
Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 300
On peut même faire un petit peu plus simple BeFax :

=SI(C3>=50;"Prioritaire";SI(C3>=25;"Important";"")) 


Tout simplement ^^
Messages postés
14200
Date d'inscription
mercredi 24 décembre 2008
Statut
Contributeur
Dernière intervention
6 août 2013
3 695
Ok, je pensais que ça n'allait pas marcher.
Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 300
Tu parles du >= ?

si c'est ça, pourquoi marcherait-il dans le cas de tester si C3 est supérieur ou égal à 50, et pas dans le cas où C3 serait supérieur ou égal à 25 ?

Finbref, ta solution fonctionne bien évidemment BeFax. La mienne est légèrement plus condensée, mais avec les fréquences de travail des processeurs actuels, la différence entre ta formule et la mienne doit se jouer à quelques nanosecondes.

Cordialement.
Messages postés
822
Date d'inscription
mercredi 15 octobre 2008
Statut
Membre
Dernière intervention
8 octobre 2011
172
bonjour;
=SI(ET(A1>=25;A1<50);"important";SI(A1>=50;"prioritaire";" "))
Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 300
Effectivement Smartway14 on peut aussi procéder de cette manière, si tu veux d'abord tester que ta valeur est supérieure à 25.

Il y a un paquet de combinaisons possibles.
Super
la formule fonctionne parfaitemen
merci du service
cordialement